View Only
  • 1.  Deleted Datastore showing up from vSphere server

    Posted Jan 12, 2012 05:13 PM

    I have an ESXi 4.1 host which is managed by a vCenter server. The host has local storage on RAID-5, and one of the drives failed. After I moved all my VM's off of it to another host I decided to re-structure how my RAID-5 is configured. I deleted the virtual disk in the RAID card BIOS and create a new one. Now part of my problem could be because I still had a few VM's on this datastore. When I brought the server back up and connected to it through my vCenter server, I tried to delete the old datastore that didn't exist anymore. It was odd because it said "Normal" for it's status... anyway when I tried to delete it I get the following error: Call "HostDatastoreSystem.RemoveDatastore" for object "datastoreSystem-82" on vCenter Server "servername.domain" failed. But when I connect directly to the host using the vSphere client, the old datastore isn't there, yet it still shows up in vCenter. I've tried rebooting the host and the vCenter server to no avail.

    I've done some searching on the internet and found a few threads on this forum but none seem to be the exact same situation so some of the fix suggestions don't apply. I'm still actively working on the problem so I haven't tried everything. I just tried the "rescan for datastores" option and am going to reboot both the host and vCenter server and see what that does. Hopefully this isn't too hard to fix...

  • 2.  RE: Deleted Datastore showing up from vSphere server

    Posted Jan 12, 2012 09:09 PM

    It seems rescanning the datastores did the trick. I rebooted both my host and the vCenter server so I don't know which of those helped, or both, but the old datastore is gone now.