vSphere Storage Appliance

 View Only
  • 1.  DataStore 2 VVOL Migration Problem

    Posted Feb 05, 2016 05:09 PM

    I have 13 VMs that I cannot storage migrate from a DataStore to a VVOL and  I cannot find anything that these VMs have in common that might be causing this.

    Anyone else see this before. I have a call open with support, but they cant figure it out either.

    This is the error I receive.

    Failed to create one or more destination disks.

    A fatal internal error occurred. See the virtual machine's log for more details.

    Failed waiting for data. Error 195887107. Not found.

  • 2.  RE: DataStore 2 VVOL Migration Problem

    Posted Feb 13, 2016 12:48 AM

    Can you share the SR number in a private message with me please?

  • 3.  RE: DataStore 2 VVOL Migration Problem

    Posted Feb 17, 2016 09:19 PM


    I did see this issue sometime in the past. I don't recollect what was the root cause though. I would check the vMotion networking and also see the following KB article if it helps.

    VMware KB: After upgrading to ESXi 6.x, vMotion fails with the error: Failed waiting for data. Error 195887179. Conn…

  • 4.  RE: DataStore 2 VVOL Migration Problem

    Posted Mar 02, 2016 12:58 AM

    We recently had the same problem with around 40 VMs (in an environment of ~190 VMs) as we transitioned to VVOLs.

    A lot of them were P2V'd or came from Xen systems years ago.

    I discovered that the Hard disks assigned to the VMs were often not aligned to GB boundaries.

    For example, one system I migrated today (which had previously failed with the error you are reporting) had a Hard disk size of: 18.1378173828125 GB

    I modified it to 20 GB, then repeated the migration and it worked... I have since repeated this procedure for a dozen more VMs.

    For the record, we are using an Equallogics iSCSI 10GBE SAN.

  • 5.  RE: DataStore 2 VVOL Migration Problem

    Broadcom Employee
    Posted Mar 03, 2016 05:31 AM

    That makes sense, and not because GB-alignment is needed but because vmdk sizes are supposed to be even 1MB multiples.  You cannot create a vmdk in the UI in other than 1MB multiples and VVol sizes are specified in MB.  If you have a disk with an odd non-MB multiple size (as a result of a VM conversion, for instance), change the vmdk size to an even MB-multiple before attempting the migration and then the migration should succeed.

    Note that it doesn't matter what size the filesystem is in the guest OS - it's the vmdk size (which would appear as the physical device capacity to the guest OS) that matters.

    Hope that helps.

  • 6.  RE: DataStore 2 VVOL Migration Problem

    Posted Mar 21, 2016 08:24 PM

    I am having the same issue.

    Any other suggestions?  I have modified my vm to be 32,768 MB (32GB) to try and fix it with no luck.  I wasn't having this issue last week with migrating to VVOLs, but now almost every vm i try is having this error?  Am I missing something in the above recommendations?  Aren't you just modifying the virtual disk in vSphere to be 1024x32, so my example above of 32,768MB should be fine as 32GB, correct?

  • 7.  RE: DataStore 2 VVOL Migration Problem

    Posted Mar 22, 2016 12:09 AM

    I made sure that the drop-down was showing GB when I made modifications to the Harddisks.  Make your're doing it for all of them present on the VM (The web GUI seems to hide the 3rd disk and beyond behind another button.)

    That solved it for me.  Good luck.