vCenter

 View Only
  • 1.  Customization Specification not working

    Posted Nov 04, 2010 10:39 PM

    When I create a RHEL5 VM using a customization specification in vCenter server, it won't populate the default gateway. Has anyone seen this issue? It populates the IP address, subnet mask, DNS servers, etc., but not the default gateway. This is vSphere4

    Thanks!



  • 2.  RE: Customization Specification not working

    Posted Dec 08, 2010 03:40 PM

    I ran into the same thing when doing RHEL5 customizations. However, networking works and if you type 'route' or 'netstat -nr' you will see the default gateway is setup. I found that it is creating files in /etc/sysconfig/network-scripts/ called 'route-' or 'route-eth0' in my case. This is where the gateway is being set. Not sure why it does it in this manner, but it works just fine. You just don't see a gateway if you use the network administration GUI in Gnome to view the settings.



  • 3.  RE: Customization Specification not working

    Posted Dec 09, 2010 06:34 PM

    OK thanks



  • 4.  RE: Customization Specification not working

    Posted Dec 09, 2010 06:36 PM

    I think the only question remaining is - what if there are multiple nics - if their default gateways don't show up in the gui - are they being all assigned to one default gateway - or can they still be assigned separate gateways? How would I check this?



  • 5.  RE: Customization Specification not working
    Best Answer

    Posted Dec 09, 2010 06:52 PM

    If you are deploying a machine with multiple vNICs, when you edit the customization specification and select Custom Settings under network, you configure each vNIC independently. So you would just select New to add more vNIC customizations and in each one you specify a gateway (in addition to the IP and Subnet Mask). The machine would have a seperate default gateway defined for each vNIC. You should see these files in /etc/sysconfig/network-scripts. For example, if you have 2 vNICs you should see 2 files called route-eth0 and route-eth1 in this directory. These files will have the default gateway defined for eth0 and eth1 respectively.



  • 6.  RE: Customization Specification not working

    Posted Dec 09, 2010 07:09 PM

    OK great thanks