vSphere Storage Appliance

 View Only
  • 1.  Correct steps to remove a datastore in vmware

    Posted Jul 31, 2017 04:53 PM

    Good afternoon mates,

    To remove a datastore in vmware, I must follow the following step:

    1-Unmount all my Host Esxi from the datastore that I will remove. Since the datastore can see all my Esxi.

    2- Remove the datastore to be deleted.

    3-Delete datastore.

    These three steps that I am indicating are the correct ones to execute?

    Waiting for your comments.

    Regards...



  • 2.  RE: Correct steps to remove a datastore in vmware

    Posted Jul 31, 2017 11:33 PM

    Assuming you're using vSphere 5.x/6.x, check the following VMware KB article: How to unmount a LUN or detach a datastore device from ESXi hosts (2004605) | VMware KB

    About your steps, the number #1 is OK, but number #2 and #3 seems confusing.



  • 3.  RE: Correct steps to remove a datastore in vmware

    Posted Oct 02, 2017 11:05 AM

    Hi jlovera,

    You will need to perform two steps:

    1. Unmount the datastore
    2. Detach the LUN

    Deleting the VMFS file system from the LUN is not required, unless you want to recreate it for some reason, such as replacing VMFS5 with VMFS6.



  • 4.  RE: Correct steps to remove a datastore in vmware

    Posted Aug 08, 2023 10:12 AM

    I found this video very helpful. Need to follow all these steps where applicable to completely remove datastore.

    https://www.youtube.com/watch?v=bW2TX2vlRXI



  • 5.  RE: Correct steps to remove a datastore in vmware

    Posted Dec 13, 2023 12:07 AM

    It's old question,. But... I had a chance to remove big 10 extend datastore from 30 hosts. And it is not as easy.

    What happened - if I detach (unmap) lun on SAN system, then
    - if I am lucky and host runs adapter scan before it try to restore MPIO everything is good
    - if host manage to run VMFS scan or MPIO scan before I run adapter-s scan, then I have 5 - 10 minutes when scans are frozen
    - if I by mistake run VMFS scan when lun is detached but adapter scan was not done, then I may have forever frozen scans and the only way out is to reboot host.

    Vmware has few issues here. First, why, when I unmount DS on host, this host is still shown in the list of hosts for this datastore? Why system try to access MPIO disks even if DS is unmounted? And why host list do not shows that DS is unmounted?