Backup & Recovery

 View Only
Expand all | Collapse all

Copied VM issue

  • 1.  Copied VM issue

    Posted Aug 27, 2020 03:33 AM

    Hi,

    I used vSphere client to download a vm. I upload the vm into another host and tried to boot it up but got an error (error below). Only then I realise that the actual vm has snapshots. When I compare the two vm from two different host, the files are different. Can anything be done to make the copied vm work? Can anyone help? Thank you.

    ====================================================================================

    Failed to start the virtual machine.

    Module Disk power on failed.

    Cannot open the disk 'SBFile2012-000001.vmdk' or one of the snapshot disks it depends on.

    The system cannot find the file specified

    VMware ESX cannot find the virtual disk "SBFile2012-000001.vmdk". Verify the path is valid and try again.

    ====================================================================================



  • 2.  RE: Copied VM issue

    Posted Aug 27, 2020 05:10 AM

    Hello Azard,

    Basically your issue is that you do not have the descriptor file that is mentioned there. Of course you can try to recreate it but i would recommend to first delete the snapshot and then do the copy again. Also if you have vCenter Server you can clone the VM so everything will be the same and you won't need any manual interaction.



  • 3.  RE: Copied VM issue

    Posted Aug 27, 2020 06:35 AM

    Hello Lalegra,

      Can you guide me on how to recreate it? The issue is the vm is 700GB and it is in Sydney while I am in Singapore.



  • 4.  RE: Copied VM issue

    Posted Aug 27, 2020 06:46 AM

    Could you please browse the datastore and from inside it download the .vmx and zip it here?



  • 5.  RE: Copied VM issue

    Posted Aug 27, 2020 06:56 AM

    Attached is the vmx file from the source. I have one more vm that I will be working on and that too having snapshots.



  • 6.  RE: Copied VM issue

    Posted Aug 27, 2020 07:08 AM

    Hello Azard​,

    As you do not have the "delta" file that references to the snapshot, the .vmsn file became orphaned. Probably if you try to see the snapshot from the "Manage Snapshot" option once stepped on the VM you will see nothing.

    I can see on the .vmx that is still referencing to: scsi0:0.fileName = "SBFile2012-000001.vmdk"

    What you can do is to modify the vmx and change that line with the actual .vmdk that you have on your VM: SBFile2012.vmdk (Please corroborate if the name is correct). After doing that change the VM should be able to power on.

    Please just in case first save a copy of the .vmx on your computer.



  • 7.  RE: Copied VM issue

    Posted Aug 27, 2020 07:47 AM

    Hello Lalegra,

    I have done as you told. Vm can boot up but it does not seem to be at the last state I backup.



  • 8.  RE: Copied VM issue

    Posted Aug 27, 2020 08:02 AM

    That is because you were having an Snapshot and all your changes were being written there. I am not sure if it is possible to recreate the descriptor file for the *-000001.vmdk disk without a delta file.

    I would mention here a.p.​ because he recently solved one of those issues and maybe he can point you on the correct direction.



  • 9.  RE: Copied VM issue

    Posted Aug 27, 2020 08:15 AM

    Thank you for your advices. I appreciate it. What do you mean at the last line?



  • 10.  RE: Copied VM issue

    Posted Aug 27, 2020 09:57 AM

    According to screenshots that you provided in your initial post, the VM has an active snapshot that holds ~650MB of changed data (that's what you are missing now).

    There's unfortunately no way to recover that data, except for copying the "SBFile2012-000001.vmdk" (the descriptor file) as well as the "SBFile2012-000001-delta.vmdk" (the data file) files over from the original location. Since you've changed the .vmx file, and powered on the VM from the base virtual disk, I'd recommend that you copy all files again to avoid possible data loss, or corruption.

    André



  • 11.  RE: Copied VM issue

    Posted Aug 27, 2020 12:35 PM

    Thank you for your reply Andre. If I am to recopy the vm again using the vSphere client, should I copy or download the vm. We have limited tools at site as it is a factory. I also read that I should have consolidated the snapshots before copying the vm.



  • 12.  RE: Copied VM issue

    Posted Aug 27, 2020 01:02 PM

    Snapshots for production systems should only be kept as long as required, so you may delete/consolidate the snapshot before you copy/export the VM.

    Assuming that the target host is running the same, or a newer version, I'd probably export the VM to OFV/OVA, and import it on the target host. Please remember that this can only be done while the VM is powered off. Prior to exporting the VM, also ensure that the VM's virtual CD-ROM drive is set to e.g. Client-Device, i.e. has no ISO-Image configured.

    Another alternative - in case the hosts are in the same location - could be https://www.virtuallyghetto.com/2012/06/how-to-copy-vms-directly-between-esxi.html, which I've used several times in the past.

    André



  • 13.  RE: Copied VM issue

    Posted Aug 27, 2020 01:19 PM

    It seems like you did not move the VMDK (VM disk descriptor file)
    Instead of copying file by file, why don't you export the VM as OVF and import it on the new host?
    How to Export a vSphere ESXi 6.7 Virtual Machine

    How to Deploy a VM from an OVF on ESXi 6.7

    Hope that works