vSphere vNetwork

 View Only
  • 1.  Configuring Different IP Segments in a VM

    Posted Jun 23, 2010 05:36 PM

    This is my first post, although I've been using the communities for quite a while.

    Currently, our VM environment contains two hosts and a Dell MD3000i SAN, hooked up to two Gigabit switches that have management pages. Each of the hosts has four NICs, which are also connected to the same Gigabit switches.

    I've created a Win2k8 R2 VM with 3 vNICs. The three IP addresses that it has are:

    192.168.0.x

    192.168.130.x

    192.168.131.x

    Our SAN has four NICs on it as well and are configured as follows:

    192.168.130.x1

    192.168.130.x2

    192.168.131.x1

    192.168.131.x2

    There is no problem in getting the VMware iSCSI initiator to connect the hosts to the SAN because I can see the VMFS volumes that I have created on the SAN in vSphere Client and I can also open up the VM consoles, connect to the VMs using RDP, and access network shares.

    The problem I have with the above mentioned VM (and any VM I tried this on for that matter) is getting the different IP segments to see each other. For example, in the above VM, if I try to access the management page of the 130.x or 131.x switch through the VM, it doesn't work. If I try to ping the management page for the respective switch, I get a Request Timed Out error message.

    I'm stumped on what it could be. I don't believe it's cabling because I can see the VMFS volumes on the SAN in the Storage Configuration section of vSphere Client and I can remote into any of the VMs that are on either host.

    Any ideas?



  • 2.  RE: Configuring Different IP Segments in a VM

    Posted Jun 23, 2010 06:02 PM

    Did you try to switch the port groups for 192.168.130.x and 192.168.131.x or switch the IP settings for the virtual NICs in Windows 2008. Maybe Windows enumerates the NICS in another order as expected.

    André



  • 3.  RE: Configuring Different IP Segments in a VM

    Posted Jun 23, 2010 06:10 PM

    Yes, I tried that.

    Windows 2008 numbered the NICs at #1, #2 and #3.

    #1 is assigned the 192.168.0.x address

    #2 is assigned the 192.168.130.x address

    #3 is assigned the 192.168.131.x address

    I tried swapping around #2 and #3 with no change.