Automation

 View Only
  • 1.  Cannot update vmware modules today

    Posted Sep 28, 2021 09:11 AM

    Just trying to update the vmware powershell modules but gets the following error:

    PackageManagement\Install-Package : The module 'VMware.VimAutomation.Sdk' cannot be installed or updated because the authenticode signature of the file 'VMware.VimAutomation.Sdk.cat' is not valid.
    At C:\Users\admjkj\Documents\WindowsPowerShell\Modules\PowerShellGet\2.2.5\PSModule.psm1:13069 char:20
    + ... $sid = PackageManagement\Install-Package @PSBoundParameters
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : InvalidOperation: (Microsoft.Power....InstallPackage:InstallPackage) [Install-Package], Exception
    + FullyQualifiedErrorId : InvalidAuthenticodeSignature,ValidateAndGet-AuthenticodeSignature,Microsoft.PowerShell.PackageManagement.Cmdlets.InstallPackage



  • 2.  RE: Cannot update vmware modules today

    Posted Sep 28, 2021 09:49 AM

    This is a known issue, see the note at the end of the blog post
    PowerCLI 12.4 - What's New - VMware PowerCLI Blog