VMware vSphere

 View Only
  • 1.  Cannot delete VMDK files automatically or manually

    Posted Apr 15, 2020 04:09 PM

    First noticed this issue when updating our Citrix Xenapp server environment with a new snapshot, it would always leave a temporary folder with the VMDK file in it.  Noticing this, I went into the SAN and browsed the storage, opened the folder and tried to manually delete the temporary VMDK file.  This results in the following:  Cannot delete file "Filename.vmdk" popup notification box.  Looking at the Task Console, I see this:  Deletion of file or directory "Filename.vmdk" from "Datastore" was initiated from 'web-client/6.5.0@' and completed with status 'Failure'.

    Not sure why this is happening but it hasn't always been the case.  Odd thing is, I can delete a new folder on the same datastore, then move the VMDK file to the new folder, and then delete it from there.  It almost seems like a permissions issue, but we haven't changed any permissions and from what I see, the Citrix service and the user account I'm using both have the Administrator role.

  • 2.  RE: Cannot delete VMDK files automatically or manually

    Posted Apr 22, 2020 01:48 PM

    I've been dealing with same issue since a new chassis/blades was configured with vCenter 6.7u3.   We have automated process to remove VMs. However, with vCenter 6.7u3 the vmdk are not getting deleted (same error msg as you). The only way I can remove these orphaned vmdk files is to log into specific blade via vsphere and delete the vmdk file. I agree it's like a permission issue, but I do not understand why logging on as administrator, I cannot delete those files in vcenter.

    We have older version of vCenter and it works fine.