ESXi

 View Only
  • 1.  cannot connect to ESXi host until shell is opened

    Posted Jan 09, 2015 01:19 PM

    I have an ESXi host running version 5.5.0, 2068190. This host is located on a different subnet from the computer I am on. Everything was working fine for the longest time, but here is the problem, that for the life of me, I cannot figure out.

    I am unable to connect to the host with the vSphere client. I cannot even ping the server. However, if I log into a machine that is local to the subnet of the ESXi host, I am able to ping and connect with the vSphere client fine. If I open a shell from a machine local to the subnet of the ESXi host, I am then able to connect across the subnet. It will actually hold for a while, then revert back to the broken state after a while. I cannot say for sure how long before it breaks again and I have to repeat the process.

    Anyone ever seen anything like this, or have any ideas? Thanks in advance.



  • 2.  RE: cannot connect to ESXi host until shell is opened

    Posted Jan 09, 2015 01:23 PM

    Did you check your router/switches and also do you have any firewall between ESXi and client computer?

    I think, this is related to your default gateways and routing tables.

    Because you can connect to that via local subnet.



  • 3.  RE: cannot connect to ESXi host until shell is opened

    Posted Jan 09, 2015 01:30 PM

    That was my first thought when I could not connect anymore, but I was able to connect to other machines crossing the networks and local to the same switch as the ESXi host.

    Remember, if I log into a machine on that subnet, I can Putty into the host. Soon as I type the username and hit enter, the machine on the other network can connect fine.



  • 4.  RE: cannot connect to ESXi host until shell is opened

    Posted Jan 09, 2015 02:22 PM

    Hi,

    if you are able to login to your host if you are located on the same vlan as the host itself, check gateway settings on the host.

    Frank



  • 5.  RE: cannot connect to ESXi host until shell is opened

    Posted Jan 09, 2015 03:19 PM

    Yeah. There aren't any vlans involved really. Everything does work locally and connectivity is fine on the host's local network. Traffic to another subnet will not work you open a shell. There may be something else that is triggering it, but this is what I found. It's weird.



  • 6.  RE: cannot connect to ESXi host until shell is opened

    Posted Jan 13, 2015 04:03 PM

    Since the machine was for test, I figured it would be fine having the vm traffic and management on the same network. This has never really caused a problem in the past. I have since put the vm traffic on a different NIC and I have not had the problem since. I am going to run with this for now. Thanks all for the replies.