ESXi

 View Only
  • 1.  Cannot access to ESXi server throught Network

    Posted Jun 07, 2013 02:23 PM

    Hi everybody!

    We have a HP C7000 Encolosure with 4 BL460c Gen 8 blades in the front size of it. In back size of the C7000 we have 2 SAN Switch, 2 HP BLc GbE2c Layer 2/3 Switch and 2 Onboard Administrator Module.

    Everything is work fine with IP Addresses like this:

    Active OA:

    IP Address: 172.16.0.253

    Stanby OA:

    IP Address: 172.16.0.254

    BL460c blade server on Bay 1:

         iLO IP Address: 172.16.0.10

    BL460c blade server on Bay 2:

         iLO IP Address: 172.16.0.11

    BL460c blade server on Bay 9:

         iLO IP Address: 172.16.0.19

    BL460c blade server on Bay 10:

         iLO IP Address: 172.16.0.20

    We can ping from pc which connected to iLO port on Onboard Administrator (OA) to that IP Addresses above. (can i call it MANAGE PC?)

    Continue, We access OA through Web https://172.16.0.253, then use Intergrated Console to control 4 blade servers. We mounted ESXi 5.1 U1 image and installed it on 4 blade servers successfully.

    We manually config the IP Address on each ESXi server (like this):

    BL460c blade server on Bay 1 as ESXi server 1:

    IP Address: 10.0.0.11

    BL460c blade server on Bay 2 as ESXi server 2:

    IP Address: 10.0.0.12

    BL460c blade server on Bay 9 as ESXi server 9:

    IP Address: 10.0.0.19

    BL460c blade server on Bay 10 as ESXi server 10:

    IP Address: 10.0.0.20

    Now, we can ping from ESXi server 1 to other ESXi server. I want to say 4 blade server can ping together.

    BUT:

    - we can't ping that blade servers from MANAGE PC (that PC connect to iLO port on OA. In this scene, MANAGE PC has IP Address 172.16.0.100/16)

    - we unplug network cable from iLO port then plug it to port number 24 on HP BLc GbE2c LY 2/3 Switch, then set IP Address of MANAGE PC to 10.0.0.100/24. Still the same, can't access that servers

    Anybody can explain me how to access that server (ping, http etc...). Do we have to config the HP BLc GbE2c LY 2/3 Switch? We read many many guide on HP website but they didn't mentioned about Routing or Switch configure

    Thanks in advance!



  • 2.  RE: Cannot access to ESXi server throught Network

    Posted Jun 07, 2013 04:43 PM

    Hi,

    Is the default gateway the same on the ESXi managment port and the MANAGE PC? are you using vLANs?



  • 3.  RE: Cannot access to ESXi server throught Network

    Posted Jun 07, 2013 05:02 PM

    Hi GFK!

    My ESXi server (in BAY 1 of C7000) had IP Address: 10.0.0.11 / 24 (i config it manually). I set IP Address of the MANAGE PC to 10.0.0.100 / 24 then plug cable from it to port 24 on GbE2c Layer 2/3 Switch. I think they have same network address, do not need a router to communicate, may i wrong?Do Internal ports and external ports of GbE2c Layer 2/3 Switch need to be config to comunicate together?

    I don't see management port on ESXi server (becase it's blade, have nothing to plug in), can you show me i have to plug network cable to which port?

    I don't use vLANs. All hardware had default configuration. I update firmware of C7000 to newest only (version 3.71).

    I can access web interface of GbE2c Layer 2/3 Switch, then i see all ports in vLAN 1

    ESXi server accept VLAN configuration but i haven't configured it

    This is the first time i work with BladeSystem. Please help me!



  • 4.  RE: Cannot access to ESXi server throught Network

    Posted Jun 07, 2013 05:23 PM

    I do not know the C7000 but i think you need to look at  HP Virtual Connect Basics. Plz have a look at Eric Shanks' bolg post on HP virtual connect http://theithollow.com/2012/08/hp-virtual-connect-networks/



  • 5.  RE: Cannot access to ESXi server throught Network

    Posted Jun 08, 2013 02:20 AM

    I don't know my C7000 system had Virtual Connect (VC) module or not. I read some manual and HP show the VC module as interconnect module plug to a bay. I didn't see it on my system. I have only 4 interconnect module, all of them are Switches.

    Thank you, i will read the link which you show me carefully.



  • 6.  RE: Cannot access to ESXi server throught Network

    Posted Jun 08, 2013 02:44 AM

    I have just read that Blog. It's very clear and helpful but my C7000 system didn't have VC Module. Do I have to buy VC module to connect blade servers to external network?



  • 7.  RE: Cannot access to ESXi server throught Network

    Posted Jun 08, 2013 03:41 AM

    Oh yeh, VC modules are not switches. Your GbE2C's are fully managed layer 2/3 switches.



  • 8.  RE: Cannot access to ESXi server throught Network
    Best Answer

    Posted Jun 10, 2013 04:42 AM

    This is my mistake!

    My servers have 2 FlexLOM connections. Only one connection was enabled for "management network" in ESXi. I don't understand it then i enabled 2 connections. That cause outside network cannot access to them.

    I have just disabled one connection and everything work fine.

    Thank everybody!



  • 9.  RE: Cannot access to ESXi server throught Network

    Posted Jun 08, 2013 03:39 AM

    I think this is just a network issue. We use exclusively HP Blades in C7000, and have similar configurations. First 172.16.X.Y/16 and 10.X.Y.Z/24 are nowhere near on the same network. Also, your OA may need to be connected to the GbE2C with a short cable. As a last experiment, I would use the integrated remote console to set the ESXi IP to something on the 172.16.0.0/16 network and see if there is connectivity.  --John