vSphere Storage Appliance

 View Only
  • 1.  Can No Longer Mount NFS

    Posted Jun 27, 2021 01:55 AM

    After a recent reboot one of my NFS (NAS) mounts (the one containing the vCenter image) did not mount.  Other mounts on the same NAS still mounted, but the vCenter instance did not mount.

    I initially tried using the CLI to perform mount commands without success.

    I ended up going into the vSphere client and using:

    Configuration->Hardware->Storage->Add Storage

    ...I tried adding my NFS using the IP address (not hostname) - this is how the other mounts are that use the exact same IP addy. 

    The error I get is:

    Call "HostDatastoreSystem.CreateNasDatastore" for object "ha-datastoresystem" on ESXi "" failed.
    An unknown error has occurred.

    If I try to mount that same IP/path from my windows (or Mac) PC and it mounts fine.  Meaning the mount point on the NAS is working.

    Any help is greatly appreciated. I am out of the water being I cannot get into vCenter to control my VMs.

    EDIT: I forgot to mention that I am running ESXi-5.5.0-20140302001 - yes, it is an old version, but it has been running great for some time.

    Another EDIT: Some entries in /var/log/vmkernal.log

    2021-06-27T01:51:22.664Z cpu1:33935 opID=5149e36d)NFS: 157: Command: (mount) Server: ( IP: ( Path: (/vCenter) Label: (vCenter) Options: (None)
    2021-06-27T01:51:22.664Z cpu1:33935 opID=5149e36d)StorageApdHandler: 698: APD Handle 50c4285a-5a53d293 Created with lock[StorageApd0x41108d]
    2021-06-27T01:51:22.666Z cpu1:33935 opID=5149e36d)NFS: 1244: NFS FSINFO failed with NFS status 70 (Stale file handle) on Server ( Path (/vCenter)
    2021-06-27T01:51:22.666Z cpu1:33935 opID=5149e36d)StorageApdHandler: 745: Freeing APD Handle [50c4285a-5a53d293]
    2021-06-27T01:51:22.666Z cpu1:33935 opID=5149e36d)StorageApdHandler: 808: APD Handle freed!
    2021-06-27T01:51:22.666Z cpu1:33935 opID=5149e36d)NFS: 218: NFS mount status: Unable to query remote mount point's attributes

  • 2.  RE: Can No Longer Mount NFS
    Best Answer

    Posted Jun 27, 2021 02:56 AM

    I am going to answer my own problem...I simply rebooted the NAS and the mount started working again. I guess I never thought about rebooting the NAS - but that did it.