vSphere Storage Appliance

 View Only
  • 1.  Bug? @ Moving files

    Posted Mar 31, 2010 08:16 AM

    Hi,

    When I try to move a folder from a local harddisk of an ESX server (maintenance mode) to a Fibre Channel datastore, I get an error:

    A general system error occurred: internal error

    But if I exit the maintenance mode, no error any more.

    Why cannot move a folder when a server in maintenance mode? And, please specify the detail error instead of the string i mentioned above.

    Thanks.



  • 2.  RE: Bug? @ Moving files

    Posted Mar 31, 2010 11:02 AM

    Just replying to get this on my discussion list. Will try to reproduce and let you know the results.

    Marcelo Soares

    VMWare Certified Professional 310/410

    Virtualization Tech Master

    Globant Argentina

    Consider awarding points for "helpful" and/or "correct" answers.



  • 3.  RE: Bug? @ Moving files

    Posted Mar 31, 2010 03:19 PM

    Bingo. Same behavior here. Really odd....

    Marcelo Soares

    VMWare Certified Professional 310/410

    Virtualization Tech Master

    Globant Argentina

    Consider awarding points for "helpful" and/or "correct" answers.



  • 4.  RE: Bug? @ Moving files

    Posted Mar 31, 2010 03:26 PM

    Found this on vCenter logs:

    ASSERT d:/build/ob/bora-208111/bora/vpx/vpxd/vmprov/copySpecUtil.cpp:581

    efficient copy spec generation failedCouldn't find a suitable worker host for copying from (vmware-esx03.vmware.local) to (vmware-esx02.vmware.local)

    Got EOF while reading file

    Seems it is trying to copy using another host... weird stuff...

    Marcelo Soares

    VMWare Certified Professional 310/410

    Virtualization Tech Master

    Globant Argentina

    Consider awarding points for "helpful" and/or "correct" answers.



  • 5.  RE: Bug? @ Moving files

    Posted Apr 02, 2010 05:51 AM

    I believe this behavior is by design.After an ESX is put into maintenance mode, it means the ESX is ready to reboot to do any hardware maintenance(e.g. firmware upgrade). VC will avoid to run any task on this ESX, since the ESX could be rebooted at anytime.

    I am trying to reproduce this on my environment, but I need more detail.

    How did you do to move the folder? Could you please provide the detailed steps? Did you start to move the folder by the "Datastore Browser" in vSphere client?

    I tried to move a folder in "Datastore Browser" when the ESX was in maintenance mode, the task will failed with message "Could not complete network copy for file Windows_VM".

    Pingjin



  • 6.  RE: Bug? @ Moving files

    Posted Apr 02, 2010 07:34 AM

    Step:

    Right click to launch Datastore Brower to view a local partition of an ESX server which is in maintenance mode;

    Right click a Folder listed in the right panel and select Move to...;

    Select a destination from a datastore of a FC LUN.

    I know maybe it's not allowed to move files in maintenance mode, but please use a specified error message.



  • 7.  RE: Bug? @ Moving files
    Best Answer

    Posted Apr 02, 2010 09:59 AM

    It seem the issue was gone in recent build. Now we have a much more friendly error on this:

    "Could not complete network copy for file New Virtual Machine"

    Thank you so much to bring up this issue. Your input will help us to impove our product.

    Pingjin



  • 8.  RE: Bug? @ Moving files

    Posted Jul 24, 2011 12:17 AM

    The cryptic error message is stil present in 4.1 381591.