ESXi

 View Only
  • 1.  Blank vm console

    Posted Oct 11, 2011 11:04 AM

    Hi, i'm having trouble with a newly installed ESXi 5.0 server in a HP DL380 G7 hardware.

    When i try to connect to the console of a new vm, using the last vSphere Client, the virtual machine don't catch mouse or keyboard inputs and stays black indefinitely.

    This problem occours also with imported (through vCenter Converter) virtual machines, already tested with vmPlayer or actually working well under ESXi 4.1.

    What could i search in the log files?

    What could i try more?

    Thank you

    Cristiano



  • 2.  RE: Blank vm console

    Posted Oct 11, 2011 12:17 PM

    Hi

    Do you get any messages on the top (yellow pop out bar) of the console about DNS, certificate, username, etc?

    Marcin.



  • 3.  RE: Blank vm console

    Posted Oct 11, 2011 01:42 PM

    Hi,

    there are no messages on the console, just menu bar, tools bar and the black screen of the virtual machine.

    Cristiano



  • 4.  RE: Blank vm console

    Posted Oct 11, 2011 04:17 PM

    For me to understand. Does the VM (guest OS) run and you just see the black console screen or doesn't the VM boot at all?

    If the VM boots/runs, you may want to try to increase the video memory in the VM's video card settings to 32 MB.

    Also make sure there's no firewall issue blocking ports (e.g. 902)

    André



  • 5.  RE: Blank vm console

    Posted Oct 11, 2011 04:59 PM

    @golddiggie

    vSphere Client

    Version 5.0.0

    Build 455964

    VMware ESXi

    Version 5.0.0

    Build 474610

    I've set up a new test server without the newest patch, connected to the same switch with the clients (both Win7, x86 and x64). Same result: black screen!

    This server version is

    VMware ESXi

    Version 5.0.0

    Build 469512

    @André

    The guest host is running because i'm able to connect to the linux guest host via ssh, but the vSphere Client console shows the black screen.

    I have already tried to set the video ram to 32MB without success.

    Both the client and the server are in the same network 192.168.30.x/23 and the client's firewall is disabled.

    To cap it all, both servers and clients are syncronized with a ntp server.

    Cristiano



  • 6.  RE: Blank vm console

    Posted Oct 12, 2011 10:26 AM

    Update: the client works well under Windows XP, so the problem is Win7.

    Cristiano



  • 7.  RE: Blank vm console

    Posted Oct 12, 2011 01:10 PM

    In this case, check the Windows 7 firewall settings.

    André



  • 8.  RE: Blank vm console

    Posted Oct 12, 2011 02:20 PM

    The firewall is totally disabled.

    Cristiano



  • 9.  RE: Blank vm console

    Posted Oct 12, 2011 02:24 PM

    This does not necessarily help with Windows 7. You'll need to have the Firewall Service up and running with the appropriate rules set up. Even with the service disabled, Windows blocks some traffic.

    André



  • 10.  RE: Blank vm console

    Posted Oct 12, 2011 03:09 PM

    Tried with in and out explicit rules for ports 902 and 903. Same result.

    WIth same rules the connection with our other servers (ESXi 4.0 and 4.1) is working.

    Cristiano



  • 11.  RE: Blank vm console

    Posted Oct 11, 2011 04:12 PM

    Are you trying to use the client from version 4.x to connect to VM's on a 5.x host? Have you tried updating the client to match the newer host (in the cluster/configuration)?? The vSphere Client is backwards compatible, but not forwards compatible. So, you can install the very latest client on your administration computer and still connect to older hosts/clusters.