vCenter

 View Only
  • 1.  Backup of server appliance fails repeatedly

    Posted Apr 07, 2022 01:43 PM

    We have just migrated all our DC roles from an old server we wish to decommission to a new server we built.

    We therefore need to point our server appliance to this new DC for DNS. Before changing the settings in the appliance, I need to take a backup of it.

    However, trying to backup the appliance via FTP fails over and over with varying errors coming up.

    Sometimes, the backup attempt will just fail immediately with a message of "Backup job failed to complete."

    Other times, the backup will start briefly, then fail with a message of "Failed to send data to the destination server. Check network connectivity permissions or available space on the server. See logs for details."

    Yet other times, the backup will run for a while, but then it reaches about 26% after roughly 12 minutes, and it fails again. This time the message is "Timeout error with the remote server. Check or adjust the remote server configurations (eg., server timeouts, max connections per IP etc.)."

    I have tried every configuration change I can think of on the FTP server. I have tried with freeFTPd. I have tried with Filezilla. Nothing works.

    I am out of ideas. Any help would be deeply appreciated.



  • 2.  RE: Backup of server appliance fails repeatedly

    Posted Apr 08, 2022 04:27 PM

    Why not take a snapshot before making the changes ? You can revert to the old config if something goes wrong. 

    What vCenter version are you on? I am backing up 7.0.2 and the latest 7.0.3.500 with FTP.

    Can you reach the FTP server from a workstation on the same segment as vCenter?

    Can you do a large (1GB+) transfer without it disconnecting ?

     

    You haven't mentioned if you did any troubleshooting



  • 3.  RE: Backup of server appliance fails repeatedly

    Posted Aug 23, 2022 05:07 PM

    i had some failure issues using the vami backup process, turns out it was my proxy settings...
    i had to modify my /etc/sysconfig/proxy file to change to an http in the https proxy

    # Example: HTTPS_PROXY="https://proxy.provider.de:3128/"
    HTTPS_PROXY="http://myproxyfqdn.com:9090/"

    and include the vcenter and sftp in the no_proxy section

    # Example: NO_PROXY="www.me.de, do.main, localhost"
    NO_PROXY="localhost, 127.0.0.1, myvcenter.fqdn.my.doamin.com, mybackupsftp.fqdn.server.com

    of course restart services after modifying proxy

    service-control --stop --all

    service-control --start --all