ESXi

 View Only
  • 1.  all options except snapshot manager greyed out

    Posted Mar 03, 2010 08:58 PM

    hello,

    I have 2 different vm's running on an ESXi server that are having the same issue. All other VM's running on this server are fine.

    When looking at the two having issues in Vsphere both of them have all options greyed out with the exception of snapshot manager open console, add permission and report performance. Within Snapshot manager all options (go to etc) are greyed out except edit although I'm not able to make any changes within it. This occured after another person was trying to take snapshots.

    when I choose to open console the same thing happens - all options are greyed out. From the console one has nothing but a black screen and the other shows vmware waiting for connection. Neither of these vm's are critical and in fact I'm looking to remove both from the disk. I thought about just going into the data store and trying to delete things there but am unsure if that may cause other issues.

    Any suggestions would be appreciated. I do have about 15 other vm's running on this box all of which are behaving normally it's just these two having issues.



  • 2.  RE: all options except snapshot manager greyed out

    Posted Mar 04, 2010 02:00 AM

    Seems the VMs are in an undefined state. You can try restarting the management agents from the physical console of your ESX. If this do not work, enter in unsupported mode (alt+f1 on the physical console, type the word "unsupported" and type the root password). Do a "ps aux | grep ", and kill all processes related to it (should be 2 or 3 PID's).

    After that you will be able to remove the Vms from the disk.

    Marcelo Soares

    VMWare Certified Professional 310/410

    Technical Support Engineer

    Globant Argentina

    Consider awarding points for "helpful" and/or "correct" answers.



  • 3.  RE: all options except snapshot manager greyed out

    Posted Jun 05, 2010 02:00 PM

    Could it be that you have shared disks on the VMs where "Take Snapshot..." is greyed out? (e.g. for an Oracle RAC cluster)

    I suppose for shared files it is difficult to just snapshot one VM - you'd need to snapshot all the VMs in the cluster, along with the shared disk files.



  • 4.  RE: all options except snapshot manager greyed out

    Posted Feb 14, 2012 03:23 PM

    I know this reply is a bit too late, but incase if someone else comes across the same issue....

    We had a VM behaving in the same manner. I could restart /stop the VM via Powercli. But the reboot made no difference. We detached the CDROM to make sure it wasent causing the error restarted the esx hosts mgmt service but the vm was still the same. I logged in to the ESX host directly using VI client and was able to access the VM without any issues. All the options were available. I removed the VM from Inventory and readded it with a different name it still behaved in the same way when i accessed via vcenter Server and when i removed it from inventory from VI client connected to ESX host it showed up as orphaned on vCenter Server client. Finally and I dont truely know why it worked... I copied all the files from the said VM folder to a new folder on the same datastore and readded the VM to the inventory with the original VM name. The VM came up with a question about it being moved/copied, I selected Moved and the VM is now up and running.