ESXi

 View Only
  • 1.  Accessing VM Serial Port Connection Issue

    Posted Jun 22, 2017 05:40 PM

    I'm trying to setup a serial port connection to a VM to gain console access to it remotely.  But when I try and follow the documentation, I end up getting my telnet connection requests rejected (fast reject).

    I've setup my VM (Cisco virtual WLC).  I added in a serial port with the following settings.

    • Use Network
    • Server (VM listens for connection)
    • Port URI= telnet://:12345
    • Yield CPU on poll is checked

    I then went to the Configuration tab on the ESXi 6.0 server hosting the VM, selected Security Profile and then clicked on the Properties of the Firewall.  I then checked the "VM serial port connect over network" option and hit OK.

    I powered on my VM and then attempt the telnet connection from my Mac, targeting the management IP of the ESXi server and the port called out in the serial port config.

    telnet 192.168.1.112 12345

    Trying 192.168.1.112...

    telnet: connect to address 192.168.1.112: Connection refused

    telnet: Unable to connect to remote host

    So it rejects with a fast reject (not a time out).  That implies the ESXi server is actively rejecting the attempt.  I can telnet to the ESXi server on other ports that I know the ESXi server is listening to (like port 8000) and that works.  So the server seems to not be opening up the port that I call out in the Serial Port config.

    Not sure if it matters, but this ESXi server is being managed by a vCenter Essentials server.  For giggles, I tried this on a different VM (different OS) and see the same result.  I also tried on another one of my ESXi servers and also saw the same thing there.  So it doesn't appear to be isolated to this one particular VM, VM type, or ESXi host of mine.

    I'm at a loss for what to do next.  Any ideas?



  • 2.  RE: Accessing VM Serial Port Connection Issue

    Posted Jun 22, 2017 05:49 PM


  • 3.  RE: Accessing VM Serial Port Connection Issue
    Best Answer

    Posted Jun 22, 2017 06:39 PM

    Thanks for the link.  These are the steps that I tried to follow as best as I could and wound up with the issue that I mentioned.

    Fiddling around with things a bit more, I found another piece of info that led me to the source of the issue.  So once I had my VM powered on with the Serial Port configured as mentioned in my original post, I looked at the VM settings.  When I select the Serial Port, it's set to connect at power on, but the Connected box wasn't checked.  If I check the Connected box and click OK, it gives an error.

    Serial port (serial0) connection control operation failed.

    Searching for that error lead me to a forum than then revealed that I need a full Enterprise license to support remote serial ports.  I only have essentials.

    Bummer!  At least I know now and maybe others might stumble upon this.  I sort of wish it would have given me an error at the time of adding the serial port to inform me of this.