Fusion

 View Only
  • 1.  Restricting cursor to VM window

    Posted Jun 24, 2007 09:28 PM

    Forgive me, I'm running a pretty low res virtual machine of Windows ME on a Macbook to play some old games (I know this is asking for trouble). Nonetheless, the VM window doesn't seem to 'grab' the cursor., i.e. I can mouse straight from OSX into VM and out again.

    I really need the VM window to restrict the cursor to give me more control. Any ideas which driver would help (in VM Tools, for instance)?

    This really is impressive software - there's pretty good Direct 3D support of Half Life!

    Thanks in advance!



  • 2.  RE: Restricting cursor to VM window

    Posted Jun 24, 2007 09:32 PM

    Hi offspinner,

    This is covered in the release notes at http://www.vmware.com/products/beta/fusion/releasenotes_fusion.html :

    Customizing the virtual machine's mouse settings for playing games

    Most games require some custom mouse settings to work correctly. These settings lock the mouse to the virtual machine when you are running a game. Note: these settings will affect the performance of the mouse and disable the ability to move the mouse between the virtual machine and your Mac. The setting in the user's preference file will also prevent the use of the drag-and-drop feature from all virtual machines to the host machine. Remove the settings to revert back to default behavior.

    To customize the virtual machine's mouse settings for playing games, use TextEdit to make the following changes while the virtual machine is powered off:

    In the virtual machine directory, add the following line to the end of the virtual machine's configuration (.vmx) file:

    vmmouse.present = "FALSE"

    In your home directory, add the following line to the end of the file /Library/Preferences/VMware Fusion/preferences:

    pref.motionUngrab = "FALSE"



  • 3.  RE: Restricting cursor to VM window

    Posted Jun 24, 2007 10:10 PM

    Thanks for the reply - I must read release notes in greater detail in future.

    It seems the mouse is locked in the window when using the windows desktop now (as requested) but when a game starts, the mouse becomes disabled - am I doing something stupid? I'm using the intellimouse ps/2 driver.

    Thanks again.



  • 4.  RE: Restricting cursor to VM window

    Posted Jun 24, 2007 10:29 PM

    Success! Seem to have cracked this by changing the setting in the Library Preferences file but NOT the vmx.

    Thanks for pointing me in the right direction.