VMware Workstation

 View Only
Expand all | Collapse all

Problem with Google Chrome popup windows

  • 1.  Problem with Google Chrome popup windows

    Posted Mar 27, 2019 12:02 PM

    Since v15 I have the shown problem with Google Chrome in W10 Machines...



  • 2.  RE: Problem with Google Chrome popup windows

    Posted May 08, 2019 03:12 PM

    Same problem here with Workstation Pro 15.0.4 build-12990004 and vmware tools 10.3.2 build-9923505 running windows 10 guest and chrome 74.0.3729.131

    The faulty rendering goes away if I turn hardware acceleration off in chrome, but that's not a solution because I'd like to use the hardware acceleration.

    Could someone from the vmware team please investigate this misbehaviour?

    Regards



  • 3.  RE: Problem with Google Chrome popup windows

    Posted May 08, 2019 03:13 PM


  • 4.  RE: Problem with Google Chrome popup windows

    Posted Sep 06, 2022 01:50 AM

    Awesome solution. It also works in Edge hardware acceleration off . Thanks



  • 5.  RE: Problem with Google Chrome popup windows

    Posted Dec 27, 2020 08:03 PM

    I am not sure whether you were able to figure it out but I recently had the same issue so I did this and it addressed the problem:

    1. Open Settings from the Chrome menu (top right of browser window).

    2. Search for "hardware" and then disable the "Use hardware acceleration when available" setting.



  • 6.  RE: Problem with Google Chrome popup windows

    Posted Oct 20, 2021 11:41 AM

    This bug is still present in Workstation 16.2.0 Pro and VMware tools 11.3.5-18557794

    It is not present when installing/downgrading to VMware tools 11.1.5-16724464.

    Please note! It is NOT a solution to disable hardware graphics acceleration in chrome because I want and need hardware graphics acceleration.

    And the bug shows up in standalone clients like nextcloud client for windows, which seems to be based on the chromium rendering engine.

     



  • 7.  RE: Problem with Google Chrome popup windows

    Posted Dec 18, 2021 10:23 PM

    Interestingly, Microsoft Edge (another chromium fork) does not suffer from this bug. I agree with level420 that disabling 3D acceleration is not acceptable which every solution to date does either through settings, flags, or CLI as evidenced by chrome://gpu.



  • 8.  RE: Problem with Google Chrome popup windows

    Posted Dec 18, 2021 11:54 PM

    Did you try changing the ANGLE graphics backend to OpenGL as mentioned here

    https://communities.vmware.com/t5/VMware-Workstation-Pro/White-text-on-white-bg-in-Chrome-under-Workstation-15-Pro/m-p/2855647/highlight/true#M170466

    Go to chrome://flags/#use-angle

    It is likely there are many different factors at play here such as host graphics cards and host OS. I don't encounter that problem with a Linux host with Nvidia GPU in a Windows 10 VM with Chrome. Several years back, there was another post that has the white background problem with a Windows host with Intel GPU. The problem goes away if Workstation Pro/Player is switched from used DX11 to OpenGL. But that is a different workaround than the ANGLE workaround; but it does let you keep the hardware acceleration turned on in Chrome.

    In the vmx of the VM, shutdown the VM BEFORE adding these lines

    mks.enableDX11Renderer = "FALSE"
    mks.enableOpenGLRenderer = "TRUE"

     



  • 9.  RE: Problem with Google Chrome popup windows

    Posted Jan 10, 2022 03:32 PM

    Changing the ANGLE backend to OpenGL only "fixes" the issue by disabling hardware acceleration completely as evidenced by chrome://gpu. Similarly, changing the MKS renderer in the vmx file to OpenGL has the same effect (Yes, of course I made the change while the guest was shutdown). This is further verified when vmware-vmx.exe and mkssandbox.exe no longer appear in the NVidia Activity monitor. A windows guest on a windows host must use DirectX in order to achieve 3D acceleration as stated in the following articles (and elsewhere in the community):

    https://docs.vmware.com/en/VMware-Workstation-Pro/16.0/com.vmware.ws.using.doc/GUID-EA588485-718A-4FD8-81F5-B6E1F04C5788.html#GUID-EA588485-718A-4FD8-81F5-B6E1F04C5788

    https://docs.vmware.com/en/VMware-Workstation-Pro/16.0/com.vmware.ws.using.doc/GUID-F5186526-2382-4F4A-8009-3D07773A1404.html

    Thank-you for your diligence.



  • 10.  RE: Problem with Google Chrome popup windows

    Posted Jan 10, 2022 11:22 PM

    protonpony,

    What is the GPU on your host? If your GPU does not support OpenGL 4.x that could be the reason why hardware acceleration becomes disabled on the VM (and as a consequence on Chrome) when switch is made to GLRenderer. What is the virtual hardware version of the VM? You might need at least version 12. I never ever tried GLRenderer on Windows host that before version 12.

    I don't know where the root of the problem lies. This problem has been around for some time (maybe since version 12.5.x, could be earlier) but does not seem to have affect all configurations (host GPUs). The reason I stumbled on the OpenGLRenderer workaround was the problem did not show up when running on Fusion on MacOS did not exhibit those problems (at that time Fusion was still using OpenGL renderer to deliver DX10/OpenGL 3.3 on Windows VMs, current version now use only Metal). The problem also does not show up on VMs running on Linux hosts as Workstation Pro/Player uses GLRenderer for accelerated graphics.



  • 11.  RE: Problem with Google Chrome popup windows

    Posted Jan 11, 2022 10:04 PM

    Hardware Compatibility is Workstation 16.x. My GPUs are NVidia Geforce GTX 1050Ti and Intel HD Graphics 630. Both of them support OpenGL 4.x and I can reproduce the problem using either one. However ANY GPU on a Windows 10 host running VMware Workstation 16 Pro with a Windows 10 guest will exhibit the problem in Google Chrome. I challenge you to submit any reproducible configuration meeting the above criteria that solves the problem very clearly defined in my third post. The other configurations and platforms you cited are irrelevant to this issue.

    You're correct, it has existed for far too long as it affects hundreds, if not thousands of users with and without support agreements. VMware developers should have addressed it by now since Chromium developers have clearly identified the VMware SVGA driver as the root of the problem (per my fourth post). Notice that I personally did not initiate this thread, and modest amount of Google searching will reveal numerous reports of the same issue encountered worldwide. I simply use an alternate browser in my Windows VMs due to the bug, and I imagine many others do the same. However, it's time someone compelled VMware to acknowledge and accept responsibility for it choosing either to devote resounces towards a solution, or to take the hit and let it ride.



  • 12.  RE: Problem with Google Chrome popup windows

    Posted Jan 11, 2022 10:55 PM

    I don't get that problem (white screen, rendering problemsw with Chrome) with a laptop with Skylake CPU HD630 with GTX 960M on a Windows 11 Home host. Switching to GLRenderer for VMware Workstation also does not disable 3D acceleraton (i.e. mks-sandbox.exe still appears on GPU Activity and Chrome inside still has "Hardware Acceleration"). With laptops, Nvidia Control Panel lets you choose a Default graphics processor so there is no need to use mks.dx11.vendorID to choose. With Intel HD630 as default and OpenGL renderer in the vmx, the horrible rendering problems even with Windows logon/menus still occur though.

    So it is strange that once you switched to GLRenderer that the Nvidia GPU is not being used and 3D acceleration is disabled (hence disables Chrome graphics acceleration). Unless the vmx entries you added resulted in disabled DX11renderer and the GLRenderer was not enabled (typo error perhaps??)

    As I said, I don't know where the root cause of the problem. If the problem was solely on the SVGA driver, how does that explain it does not seem to happen on Windows VMs that run on Workstation on Linux hosts and macOS Fusion? Just relying on Chromium developer comment also does not explain why it does not happen to your Edge browser. There was another recent post where the user encountered render problems with Opera, Brave and Viber. Both Opera and Brave are also Chromium-based. Viber appears to be written using Qt framework (therefore using ANGLE). So it may not be just Chrome/Chromium specific but rather with ANGLE and/or combination when VMware Workstation Pro/Player uses DX11Renderer (which probably explains why VMware users with Linux hosts and macOS Fusion users does not seem to encounter the Chrome render problems) and generally using the GLRenderer on Windows 10/11 host works around the problem.



  • 13.  RE: Problem with Google Chrome popup windows

    Posted Jan 11, 2022 11:20 PM

    Are you validating your results by browsing to chrome://gpu? Just because the switch enabling hardware acceleration in the advanced section of Chrome's settings is ON does not necessarily mean that Chrome is actually using hardware acceleration. Additionally, I haven't found any VMware documentation offically stating that 3D acceleration on a Windows host/guest configuration is even possible using OpenGL. In fact, the following article suggests exactly the opposite. Again, just because the setting exists in the vmx file doesn't mean the functionality is there to back it up. 

    https://docs.vmware.com/en/VMware-Workstation-Pro/16.0/com.vmware.ws.using.doc/GUID-EA588485-718A-4FD8-81F5-B6E1F04C5788.html#GUID-EA588485-718A-4FD8-81F5-B6E1F04C5788

    Operating Systems are vastly different. Stating that a driver should work on one OS because it does on another is ludicrous. The scope of this problem is defined (at a minimum) as a Windows 10 guest on a Windows 10 host running VMware workstation 16 Pro, period. A successful test on that configuration must demonstrate hardware acceleration in Chrome by browsing to chrome://gpu without exhibiting the visual anomaly.



  • 14.  RE: Problem with Google Chrome popup windows

    Posted Jan 12, 2022 12:08 AM

    Yes, I also look at chrome://gpu. Same with edge://gpu If you notice with edge://gpu changing the use-angle to OpenGL does not make a difference in the GL_RENDERER in the VERSION INFORMATION section of edge://gpu

    Using GLRenderer for Windows 10/11 hosts is not officially supported. As I had already mentioned, I only stumbled upon it because at that time I also had Fusion 8.x (which used OpenGL) running with MacBook Pro with Iris Pro 5200. Fusion 12.x now exclusively uses Metal. On Linux hosts, GLRenderer is still used as the default although VulkanRenderer should also be an option with version 16.x. Some of the code is shared between the 3 different platforms. As it is GLRenderer is still available for Linux hosts, the code should work as well for Windows hosts. Of course one cannot expect the Metal options to work for Linux/Windows or DX11 to work for Linux/macOS hosts.

    As GLRenderer on Windows hosts is not officially supported, one would also accept the risk that there could be other problems/side-effects encountered (like rendering problems like Windows VM logon/menus with the HD530/GLRenderer combination).

    I just find it strange in your case the VM 3D acceleration graphics gets disabled when you disabled the DX11Renderer. A possible explanation is GLRenderer was not enabled (maybe because of typo error???). Anyway here is the mks-sandbox.log entries with a GTX960M on Windows 11 host using GLRenderer. The GPU Activity show mkssandbox.exe as active and 3D acceleration remain enabled in the VM (and as consequence Chrome as well in the chrome://gpu).

    mks MKS Win32: MIL: 0x2000
    mks MKS-RenderMain: PowerOn allowed GLRenderer
    mks MKS-RenderMain: ISB not enabled by config
    mks MKS-RenderMain: Collecting RenderOps caps from GLRenderer
    mks MKS-RenderMain: Starting GLRenderer
    mks GLHostWin32: : Created context with GL 2.1, core: 0, robust: 0
    mks GLHostWin32: : Created context with GL 4.0, core: 0, robust: 1
    mks GLRenderer: OpenGL Version: "4.6.0 NVIDIA 496.13" (4.6.0)
    mks GLRenderer: OpenGL Vendor: "NVIDIA Corporation"
    mks GLRenderer: OpenGL Renderer: "NVIDIA GeForce GTX 960M/PCIe/SSE2"
    mks GLRenderer: Driver Version: "4.6.0 NVIDIA 496.13" (496.13)
    mks GLRenderer: GLSL Version: "4.60 NVIDIA" (4.60.0)

     



  • 15.  RE: Problem with Google Chrome popup windows

    Posted Jan 12, 2022 01:01 AM

    Which MKS renderer I use is not the issue here because neither of them work. GL doesn't because, as you say, it is not supported in a Windows 10/11 host/guest configuration. The DX renderer loads but forces one to choose between the visual defect in Chrome or no GPU acceleration at all. I don't need to make a case because the sheer volume of users affected by the bug already have. This has been amazing, but I'm quickly losing interest. Our dialouge will provide insight to others who seek answers and perhaps even a degree of satisfaction. Who knows, maybe we've stirred the waters enough to prompt real action. Thank-you for the opportunity to represent.



  • 16.  RE: Problem with Google Chrome popup windows

    Posted Jan 10, 2022 04:33 PM

    Just to be clear, every solution proposed here or elsewhere on the Internet (without exception), that remedies the visual anomaly seen at the top of this thread, also produces the following results when browsing to chrome://gpu on a Windows 10 guest hosted on Windows 10 running VMware Workstation 16 Pro:

    chrome://gpu



  • 17.  RE: Problem with Google Chrome popup windows

    Posted Jan 10, 2022 05:46 PM

    According to the following bug report, chromium developers had knowledge of the problem since early 2019 and decided to blacklist the vmware SVGA driver citing time contraints, ultimately concluding it was incompatible with GPU acceleration. Curiously though, as I stated earlier, my tests indicate Microsoft Edge is not affected by the problem, suggesting their team actually found a viable workaround.

    https://bugs.chromium.org/p/chromium/issues/detail?id=929764



  • 18.  RE: Problem with Google Chrome popup windows

    Posted Mar 16, 2022 01:46 PM

    This worked, thanks.  I also noticed if disabling the 3D acceleration in settings it also resolved the issue, but I prefer having it enabled, so thanks for this workaround. 



  • 19.  RE: Problem with Google Chrome popup windows

    Posted Apr 26, 2022 02:41 PM

    For me, this workaround works very well :

    1.  let the 3D accelerated enable in Edge (or Chrome) and just disabled the shadow
    2.  disable the shadows under windows :

    nicoueron_0-1650983993758.png

    or in English :

     

    nicoueron_2-1650984038370.png

     



  • 20.  RE: Problem with Google Chrome popup windows

    Posted Oct 16, 2022 06:15 AM

    Not working on Brave Browser only disabling HW Acceleration worked



  • 21.  RE: Problem with Google Chrome popup windows

    Posted Feb 04, 2022 06:09 AM

    I also have to agree with you that disabling hardware acceleration is not an acceptable "workaround". Heck I wouldn't even consider that suggestion a workaround since it's such an important feature for many apps. Wanted to say thanks for leaving this comment as it infact helped me "fix" the issue by enabling me to leave hardware acceleration on, but not have the white screens of chromium. That being said, I can't believe it's been this long since this has been an issue and it has not yet been fixed, especially since it seems that an older version of VMware tools seems to not have this issue. I can also confirm that using version 11.1.5-16724464 works on windows 11 as well. I was having this same issue on a windows 10 host with both a windows 10 virtual machine and windows 11 virtual machine no matter what OS updates were installed on either VM, and this version of drivers fixes this issue on both while still seeming to keep functionality of hardware acceleration.



  • 22.  RE: Problem with Google Chrome popup windows

    Posted Feb 11, 2022 04:30 PM

    Thank-you for lending that very important point, one which I completely forgot to mention. My initial investigation produced many such reports of the bug's appearance loosely coinciding with the release of Workstation 16 / VMware Tools 11.2, further pinning responsibility squarely on the shoulders of VMware developers. Regardless, we need only ask which of the two concerned parties (VMware or Chromium) bears the greater burden of maintaining compatibility with the other? One reasonably expects a virtual desktop to look, feel, and perform in every way possible like the actual desktop upon which it's hosted. Any incongruency falls short of that ideal and deserves elucidation.



  • 23.  RE: Problem with Google Chrome popup windows

    Posted Mar 09, 2022 03:28 PM

    For myself, I am having this issue on a win10 VM Workstation, running on a windows 7 box.  Problem shows up for both Brave browser and MS Edge browser (v95).
    This is not an issue where there is a decent workaround (without making unusual changes).  People are not able to work if they are not able to read any pop up window or their bookmarks.



  • 24.  RE: Problem with Google Chrome popup windows

    Posted Mar 09, 2022 03:32 PM

    Today I've realized that version 12.0.0. of VMware Tools are available at https://customerconnect.vmware.com/en/downloads/info/slug/datacenter_cloud_infrastructure/vmware_tools/12_x but the bug is still present on my Windows 10 LTSC 2021 x64.

    So I'm still stuck on VMware Tools 11.1.5 which do not show the bug.



  • 25.  RE: Problem with Google Chrome popup windows

    Posted Mar 09, 2022 03:49 PM

    Installing v11.1.5 worked for me for Brave browser. However, it did not work for MS Edge v95.  Still getting white pop-up boxes for credential assistant, bookmarks, etc.

    update:  just noted that while bookmarks for Brave are now visible - credential pop up windows are still white-out.

    Update 2:  Brave pop-up windows when hovering mouse over tabs in the browser are whited out.  I had to disable hardware tags via chrome://flags/#use-angle, before I could see those again.   Doing the same hardware change for MS Edge did not work for me.



  • 26.  RE: Problem with Google Chrome popup windows

    Posted Mar 09, 2022 04:46 PM

    The bug also shows up on Windows 11 Pro even with the latest VMware Tools 12.0.0



  • 27.  RE: Problem with Google Chrome popup windows

    Posted Jun 30, 2022 09:56 AM


  • 28.  RE: Problem with Google Chrome popup windows

    Posted Apr 16, 2023 07:55 PM

    I have the same problem to vmware workstation 17 pro (chrome crashes the software). Since google refuses to fix it, decided to use edge. Turns out Edge is way better than chrome in every aspect. thanks Google for pushing us to use Edge.



  • 29.  RE: Problem with Google Chrome popup windows

    Broadcom Employee
    Posted Apr 18, 2023 01:27 AM

     , Could you please try to reproduce this issue again with Workstation 17 and upload your vmware.log and mksSandbox.log?

    I can try to take a look.

    Thank you very much!