Fusion

 View Only

Fusion - Default Gateway Change Solidify

  • 1.  Fusion - Default Gateway Change Solidify

    Posted May 03, 2023 04:37 PM

     

    I am designing a network replicate and requiring that the Default Gateway for this instance to be "10.12.11.254" and not the default ".2" of standard vmnet[s].

    I have discovered how to change my Default Gateway by making the changes below. My question is how can I solidify the Default Gateway so that closing VMware Fusion does not reset it every time? I am constantly changing this file.

     

    Change the Default Gateway address inside the VMNET interface. Working with Interface: VMNET14, Network: 10.12.11.0/24.
    Gateway currently is VMware Fusion default of .2 ( 10.12.11.2 ) and changing to .254 ( 10.12.11.254 )

    # Edit line 10, in file nat.conf, with VIM.

    sudo viM /Library/Preferences/VMware\ Fusion/vmnet14/nat.conf
         # ( Before selecting " i " to edit, :set number will give line number )

      1 # VMware NAT configuration file
      2 # Manual editing of this file is not recommended. Using UI is preferred.
      3 
      4 [host]
      5 
      6 # Use MacOS network virtualization API
      7 useMacosVmnetVirtApi = 1
      8 
      9 # NAT gateway address
     10 ip = 10.12.11.2
     11 netmask = 255.255.255.0
     12 
     13 # VMnet device if not specified on command line
     14 device = vmnet14
     15 

    # Change LINE 10 to 10.12.11.254
              # ( " i " to enter insert mode )

      1 # VMware NAT configuration file
      2 # Manual editing of this file is not recommended. Using UI is preferred.
      3 
      4 [host]
      5 
      6 # Use MacOS network virtualization API
      7 useMacosVmnetVirtApi = 1
      8 
      9 # NAT gateway address
     10 ip = 10.12.11.254
     11 netmask = 255.255.255.0
     12 
     13 # VMnet device if not specified on command line
     14 device = vmnet14
     15 

    # ( Don't for get your :wq! to save changes )

     

     # Now to restart the networking service with the new setting:
              sudo /Applications/VMware\ Fusion.app/Contents/Library/vmnet-cli --stop
              sudo /Applications/VMware\ Fusion.app/Contents/Library/vmnet-cli --start