Fusion

 View Only
  • 1.  Switching to Bridged Networking disconnects Ethernet

    Posted Dec 05, 2008 09:43 PM

    My Fusion 2.01 works fine with NAT.

    I need to use Bridged networking for Outlook at work. When I switch from NAT to Bridged, the connection on the Mac side fails and neither host nor guest can connect.

    Any ideas?

    MacBook Pro

    2.4Ghz

    OS X 10.5.5

    4Gb RAM



  • 2.  RE: Switching to Bridged Networking disconnects Ethernet

    Posted Dec 05, 2008 09:57 PM

    Just upgraded to 2.01 and experiencing similar in bridge mode It is 50/50 if interenet will crash on statup of VM. researching how to downgrade



  • 3.  RE: Switching to Bridged Networking disconnects Ethernet

    Posted Dec 05, 2008 11:52 PM

    When I switch from NAT to Bridged, the connection on the Mac side fails and neither host nor guest can connect.

    I would expect guest netoworking to fail when you switch from NAT to Bridged or if the host can't connect. However, it's strange that the host fails when you switch.

    Are you using wired or wireless (I would expect wired to work better)? What's the network topology like? Is it possible whoever's giving out IP addresses only gives out one per MAC address?

    Is the Mac getting a new IP address? Does a static IP address work?

    If you change back to NAT, does networking work?

    If you remain in Bridged and reboot the Mac, does networking work?



  • 4.  RE: Switching to Bridged Networking disconnects Ethernet

    Posted Dec 06, 2008 03:34 PM

    This is the typical scenario:

    The MacBook Pro works fine in every aspect. I run many PC and Mac applications simutaneously without issue. I use NAT and everything except using the Mail/Calendar features in Outlook/Exchange work great. There has been discussion that a direct virtual machine to network (instead of VM to Mac to Network) connection might work better with the Exchange server. So I think that implies trying Bridged instead of NAT. Willing to try to see if it solves the Outlook issue, now I encounter the problem that Bridged doesn't work at all.

    I tried these:

    1. Virtual machine ON: switched from NAT to Bridged. Mac networking control panel says: Disconnected, no IP address. PC has no connectivity either.

    2. Virtual machine OFF: switched from NAT to Bridged. Startup virtual machine. Mac networking control panel says: Disconnected, no IP address. PC has no connectivity either.

    • I am using a cabled Ethernet connection.

    • It is in a very large corporate environment, using DHCP.

    • I cannot say if it is limited to one IP address per MAC address. Doubt it, but its possible.

    • Switching back to NAT works (have to force it to refresh its IP address though, turn Ethernet off and on again).

    • Rebooting the Mac after switching to Bridged - I will test it.



  • 5.  RE: Switching to Bridged Networking disconnects Ethernet

    Posted Dec 06, 2008 04:39 PM

    Test Results:

    On my home network (both wireless and cabled) Bridged networking works just fine.

    So, its a network issue on the corporate LAN, not a local software issue.

    I still cannot connect to Exchange properly. But that's for another thread... or the hopefully short wait until Snow Leopard.