ESXi

 View Only
  • 1.  vm-guest not connecting to internet from ESX Host setup

    Posted Jan 07, 2024 11:06 PM
      |   view attached

    I've just installed ESXi 8.0 U2 with a static IP of 10.10.30.5 ( on single switch port interface with network of 10.10.30.2 to 10.10.30.15.  Imported an OVF with Win 10 (dhcp-10.10.30.3) and got connected via ESX host client (my desktop on 192.168.7.42) and can go out to internet from this guess-VM and also via a vpn setup.  I then imported Win11 and Ubuntu TLS 22 via OVF.  Both OS can run as guess-VM with dhcp addresses of .6 and .7, but both cannot access the internet.  I can see on my switch (192.168.7.1) that they are getting an IP address (as described above) and can ping locally on the ESX network to host BUT not past switch (192.168.7.1) and out to the internet.  I've also tried building the guess-VM ubuntu from scratch and used dhcp ip address ( again seen on switch) and static addressing with mask of 255.255.255.0 and gateway if 10.10.30.1 and still no internet traffic goes thru.  I can ping anything on 10.10.30.x .. but not to 192.168.7.x and beyond.  I have a FW rule on my switch to allow all traffic across 10.10.30.x to 192.168.7.x (was tested with win 11 on this rebuild box and on same 10.10.30.5) and I could access all networks and internet.  NOW that ESXi 8U2 is installed, the traffic is an issue.  On further info, the ESX is complaining that "TPM 2.0 is detected but a connection cannot be established".  NOW I do have TPM ON in BIOS since Win 11 originally would NOT have worked.  So not sure IF I would even get an IP address, like I do now, otherwise IF this TPM was off (screen-shot attached).   So I am stuck with VMs that will NOT route out to the internet and have NO idea why.  Any help/direction is welcome.  Thank you in advance



  • 2.  RE: vm-guest not connecting to internet from ESX Host setup

    Posted Jan 08, 2024 01:24 AM

    In terms of the TPM message, you may want to verify the vendor and the installed TPM 2.0 chip is on the HCL. Apparently, from reading other post, some TPM enabled hardware is not compatible. VMware also has a KB where it could be the driver for TPM if the vendor one is not native to ESXi. 

    https://kb.vmware.com/s/article/81838

    As far as network connectivity, if you do an nslookup for something like www.google.com, does it return an address or failure? It if fails, there could be a DNS issue. If it succeeds, then do a trace route and verify the gateway is where the failure actually occurs. It may not be where it seems to be on just a ping request. You may also want to compare the DNS settings on the one you imported that works vs the DHCP clients. 



  • 3.  RE: vm-guest not connecting to internet from ESX Host setup

    Posted Jan 08, 2024 04:49 PM

    thanks for the reply.  on win11 did an nslookup and i get server unknown and address of 8.8.8.8.  rest is DNS request timeout and set to 2 seconds.

    on working win 10 vm did the same and got server unknown with address 10.0.0.241.  non auth response of www.google.con with address 172.217.13.100.  tracert to google provides 8 hops to the destination with 10.8.128.1

    also asking vendor for any software driver for tpm 2 if any.

     

    so still stuck ;(



  • 4.  RE: vm-guest not connecting to internet from ESX Host setup

    Posted Jan 08, 2024 05:57 PM

    That the fact you reference 8.8.8.8 on the Win11 and 10.0.0.241 on Win10, means that your DNS settings in DHCP are not the same. 8.8.8.8 is Google's DNS server. My guess is that your other one (10.0.0.241) is an internal one? Could it be that your firewall or other security product does not allow for external lookups? If it cannot resolve DNS, there will be no connectivity. 



  • 5.  RE: vm-guest not connecting to internet from ESX Host setup

    Posted Jan 08, 2024 09:49 PM

    sorry about that...i turned off my vpn and got the following

    server: dns.google.com  address 8.8.8.8  non-auth www.google.com 142.251.41.68 on win 10. tracert is 8 hoops with first address check as 10.10.30.1

    on win 11 (no vpn installed), i setup now the ip as manual to 10.10.30.6, 255.255.255.0 gateway 10.10.30.1  dns 10.10.30.1 and 8.8.8.8

    server: unknow  address 10.10.30.1  non-auth www.google.com 142.251.41.68

    tracert times out

    i am suspecting maybe not routing well out of esx then for win 11? i used default settings

     



  • 6.  RE: vm-guest not connecting to internet from ESX Host setup

    Posted Jan 09, 2024 04:18 AM

    So it times out before even getting to the gateway?



  • 7.  RE: vm-guest not connecting to internet from ESX Host setup

    Posted Jan 09, 2024 05:21 AM

    ...and I still see the vm-guess receiving an IP from the router/FW.  Just not going beyond that.  Happens the same with my Ubuntu install.  So don't get this why.



  • 8.  RE: vm-guest not connecting to internet from ESX Host setup

    Posted Jan 09, 2024 06:27 AM

    well...well... surprise, surprise ..I revisited the FW settings and I had 10.10.30.2 to 10.10.30.5 allowed on the traffic.  Above PCs were getting .6 and .7  ..which fell outside the traffic boundary...thus ..not routing traffic across anymore.   Just adjusted that and now all good with Win 11 and ubuntu, linux mint etc...they all have traffic flow.   Looks like it was not a TPS issue after all.  This took me about a week on a day-by-day to try and solve.  Guess I should of walked away from this for a while and refresh the mind.  Coming on here to share the issue certainly helped.  Thank you for your quick reply and share of ideas.  I very much appreciate this a lot.



  • 9.  RE: vm-guest not connecting to internet from ESX Host setup

    Posted Jan 09, 2024 10:49 AM

    I thought there was a possibility of it being the firewall. That was the reason I brought it up back on 1/8.  We have had issues with the firewall configuration before because our security team has it pretty tight.