Fusion

 View Only
  • 1.  Stuck at "Start PXE over IPv4", won't launch ISO.

    Posted Sep 18, 2023 07:18 PM

    Dear All,

     

    I downloaded and installed wmware fusion on my M1 macbook air. I also downloaded windows 10 on microsoft's website. I set the Windows 10 ISO disc in settings. When I launch Wmware, it says "Start PXE over IPv4", and nothing else happens. I have uninstalled, re-installed, restarted my computer AND wmware virtual machine, I have tried deactivating TPM... nothing works. Windows 10 won't launch.

    I find it hard to find someone with the same issue on the internet. Please help.



  • 2.  RE: Stuck at "Start PXE over IPv4", won't launch ISO.

    Posted Sep 18, 2023 07:37 PM

    First off, don't even TRY to install Windows 10 on your M1 mac... only Windows 11 ARM is supported by both VMware and Microsoft.  Also, if you downloaded an ISO from Microsoft, I'd be willing to bet it's the Intel-based version, not ARM-based... and therefore will not boot/load in your VM.

    Second, refer to the instructions in Technogeezer's Unofficial Guide (see the Fusion Docs forum for the post and document) for detailed directions on obtaining the installation media and installing it.



  • 3.  RE: Stuck at "Start PXE over IPv4", won't launch ISO.

    Broadcom Employee
    Posted Sep 18, 2023 07:38 PM
    Pretty sure you need to use Windows 11 rather than 10, check this unofficial guide: https://communities.vmware.com/t5/VMware-Fusion-Documents/The-Unofficial-Fusion-13-for-Apple-Silicon-Companion-Guide/ta-p/2939907


  • 4.  RE: Stuck at "Start PXE over IPv4", won't launch ISO.

    Posted Sep 18, 2023 07:40 PM

    That error message is an indication that either

    • whatever you tried to boot from is not bootable on ARM CPUs like the M1/M2 Macs, or
    • you didn't respond to the "Press any key to boot from CD/DVD" prompt quickly enough.

    Given what you've said, I suspect the first one. Check the filename of the downloaded ISO and if it contains "x64" then that won't work on M1 Macs. Microsoft in its infinite wisdom does not have a web site where you can download the Windows version (Windows 11 ARM) that will run on ARM chip CPUs like the M1/M2 Macs.

    You will need to run Windows 11 ARM on M1/M2 Macs - it is the only version that will work (sorry, no Windows 10 or earlier versions of Windows). And be prepared for bumps in the road if you're a gamer because the 3D support is DX11 only.

    If you have a Fusion 13 version, I'd recommend uninstalling it and installing the 2023 Public Tech Preview (https://communities.vmware.com/t5/Fusion-2023-Tech-Preview/ct-p/fusion2023 ). That has much better support for Windows 11 ARM VMs than Fusion 13 does, and it's a look at what's to come later this year when VMware releases its next Fusion version. 

    Also before you start, download and review both the Tech Preview Testing Guide found at the above link, plus the unofficial Fusion 2023 Tech Preview Companion Guide https://communities.vmware.com/t5/Fusion-2023-Tech-Preview/The-Unofficial-Fusion-2023-Tech-Preview-Companion-Guide/td-p/2977869 . The unofficial Companion Guide tells you how to easily obtain installation media for Windows 11 ARM (Hint, you can't directly download it from Microsoft on the web) and how to install it. 



  • 5.  RE: Stuck at "Start PXE over IPv4", won't launch ISO.

    Posted Sep 19, 2023 09:35 AM

    First of all, thank you everyone for the quick answer.

    I was able to download tech preview and run windows 11 arm as you perfectly described it.

    This is a subsidiary question, but I still want to ask, I am now stuck on the "let's connect you to a network"  step during the installation of windows 11, it doesn't show any wifi connections and there is absolutely nothing I can click to move on, there are many wifi networks running where I am, so there must be an issue between wmware and my mac's internet connection compatibility. I have checked my network adapter settings on wmware, it is set to "share with my mac", I have also tried with other network settings in the list, but windows 11 still doesn't recognize my internet connection network.

    Do you have any ideas why? Are there any compatibility issues between wmware and mac in terms of using network, USB connection? I will use windows to run a car programming software, which I need to connect from my mac's USB port to my car's D+CAN port. Thank you!



  • 6.  RE: Stuck at "Start PXE over IPv4", won't launch ISO.

    Posted Sep 19, 2023 01:56 PM

    Just confirming: Did you install the VMware Tools using the procedures in the document after the VM boots from the hard drive for the first time?