VMware NSX

 View Only
  • 1.  ALB SE not connecting to Controller

    Posted Apr 18, 2024 12:48 PM

    Hi everyone,

    I'm deploying NSX ALB 22.1.5 onto a vSphere 7 environment, including NSX 3.2, primarily to utilize the GSLB feature set.

    Controller is configured to use the vSphere 7 Cloud for the solution, but I'm hitting an issue when deploying the SE.

    The environment is only a test/PoC for the moment with limited address space, so I've limited the SE group to only 1 SE. The SE MGMT is in a different subnet to the controller, but they are routable.

    The issue I'm currently having is that the SE is not establishing a connection back to the controller. I can ping from the controller to the SE, but when debugging with NCAT, I'm getting "connection (tcp) refused" for ports 443 and 8443. Port 22 is fine.

    The one other component that may be causing an issue here is that there is a firewall in-between the two, which I have no vision into. I've requested and been told that those ports are open between the two VMs, but now I'm not 100% certain if that's been configured correctly given this is still getting "connection refused".

    Have I missed anything in the configuration? This is a clean controller build, I haven't configured anything outside of the GSLB components and SEs. Have I missed configuring some SSL cert somewhere?

    Thanks for the help team!



  • 2.  RE: ALB SE not connecting to Controller

    Posted Apr 18, 2024 12:59 PM

    Hi

    Port 8443 needs to be allowed on the FW between the Controller and SE.

     



  • 3.  RE: ALB SE not connecting to Controller
    Best Answer