Fusion

 View Only
Expand all | Collapse all

Fusion suddenly ignoring keyboard input

  • 1.  Fusion suddenly ignoring keyboard input

    Posted Oct 29, 2007 05:43 PM

    I have a FreeBSD 8.0/amd64 VM running under Fusion. I was happy using it with the previous version (build 57nnn - 1.1fc1 IIRC) and decided to uprade to 1.1 RC build 61385. Upgrade went fine but all of a sudden, my VM refuses keyboard input and just beeps. I went back to the prevous build, same thing happen. I installed again 61385 still no keyboard input. This is on a Tiger 10.4.10 macbook pro with 2 GB of RAM (512 for the VM). The only other thing that changed was that I tried to give more memory to the VM (516 -> 768 MB).

    Any idea why this could happen? I really enjoyed Fusion compared to Parallels with amd64 & dual core CPU support but I'm ready to go back to parallels if this does not work...

    Thanks



  • 2.  RE: Fusion suddenly ignoring keyboard input

    Posted Oct 29, 2007 08:03 PM

    Can you check if any app is using SecureInput while this occurs (run "ioreg -l -w 0 | grep SecureInput" in an OS X terminal)?



  • 3.  RE: Fusion suddenly ignoring keyboard input

    Posted Oct 29, 2007 11:16 PM

    Good catch:

    209 roberto@rron:~> ioreg -l -w 0 | grep SecureInput

    | "IOConsoleUsers" = ({"kCGSSessionGroupIDKey"=501,"kCGSSessionOnConsoleKey"=Yes,"kCGSSessionIDKey"=256,"kCGSSessionUserNameKey"="roberto","kCGSessionLoginDoneKey"=Yes,"kCGSessionLongUserNameKey"="Ollivier Robert","kCGSSessionSystemSafeBoot"=No,"kCGSSessionLoginwindowSafeLogin"=No,"kCGSSessionConsoleSetKey"=0,"kCGSSessionUserIDKey"=1193,"kCGSSessionSecureInputPID"=270})

    PID 270 is Checkpoint SecureClient:

    270 ?? S 57:59.36 /opt/CPsrsc-50/bin/SecureClient.app/Contents/MacOS/SecureClient -psn_0_2228225

    Now, how to workaround that?



  • 4.  RE: Fusion suddenly ignoring keyboard input

    Posted Oct 30, 2007 12:06 AM

    One workaround is to not use SecureClient and Fusion at the same time.



  • 5.  RE: Fusion suddenly ignoring keyboard input

    Posted Oct 30, 2007 02:30 PM

    I am having the same problem with keyboard input. At first I thought it was something up with my install of the release candidate (I'd upgraded to Leopard, and then downloaded the RC while my iMac was racing between Spotlight and Time Machine on a newly attached external disk so Terminal and Disk Utility stuck while I was going to do an md5 sum of the RC's dmg) as the VMware tools disk image was broken when trying to upgrade within Ubuntu 7.10 or with the fact that the first VM I used had been suspended midflow and then copied to another disk.

    I downloaded the RC again and tried both Ubuntu 7.10 and Windows XP and both had the same problem. Coming here, I did the appropriate search for SecureInput. I expected it to be Terminal as I had (at one stage) switched secure entry on and Terminal was running but I had evidently switched it off again. I found that Opera was the program that was preventing keyboard entry as it was using SecureInput. I quit Opera and am able to type into my VMs again.

    In related news, the VMware Tools image is OK now (with my second download (md5-ed first)).



  • 6.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 03, 2007 12:29 AM

    Greetings,

    In my case, PGP Desktop turned out to be the culprit. Killing it cleared up my VM keyboard problem and, when it restarted, the problem did not reappear.

    This problem started after I installed the latest beta and then backed it out because it was causing OS X to kernel panic.

    -David



  • 7.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 03, 2007 01:42 AM

    I've had the same issue..sort of. I'm running xp32 pro in fusion, and in full-screen mode the keyboard started to "boink" and not deliver to the VM. When I switched to fusion mode the keyboard input worked. Returning to full screen broke it again. Single window mode also works.

    Leopard, RC 61385. Didn't happen before in 1.0 and betas, but today was the first day I really pushed the mac (book pro).



  • 8.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 04, 2007 05:15 AM

    Of course, if one needs to use ones VPN client to connect to resources needed for the VM, that's not a great solution. Is this issue being SecureInput issue being fixed?



  • 9.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 06, 2007 03:36 PM

    Considering that it took Checkpoint more than one year to build a Tiger-compatible of Secureclient after Tiger's release, I'm not holding my breath for that. I don't have much more hope for a Leopard-compatible one either. I think I'll move my Fusion to the other MBP I have. Bonus, it has now 3 GB instead of 2.



  • 10.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 06, 2007 09:20 PM

    Not useing SecureClient and Fusion at the same time really isn't an option. It seems it's not just SecureClient that is causing the issue but a feature of the OS that fusion can't handle if it's running. Are you working on a fix or workaround that will let us use Fusion while another app is using secure input?

    Thanks



  • 11.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 06, 2007 09:45 PM

    Do you have an ETA for a fix for this issue?



  • 12.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 08, 2007 05:56 PM

    I just found a fix for my particular problem with the keyboard not working. I don't have SecureClient so I was really confused, so I just started disabling programs in OSX. I found that XHub was causing my keyboard to stop working. Once I disabled it everything worked fine. I hope this helps someone who was as frustrated as I was.



  • 13.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 17, 2007 05:49 AM

    I have a MacBoom Pro 17" Intel Dual Core 4 Gb running Leopard as well as Vista via Bootcamp. I load VM Fusion successfully into Leopard and select Vista from Bootcamp - Fusion starts correctly with no errors. I have the same problem, however - when Fusion loads Vista, the keyboard does not respond in the Fusion window. My MacBook Pro is brand new and there are no other programs running - unless they are some native processes to Leopard. I have no idea, as I new to MAC since 1 week having made the conversion from PCs.

    Does anyone have any sggestions - please keep in mind that I am still new to the Mac system.



  • 14.  RE: Fusion suddenly ignoring keyboard input

    Posted Nov 17, 2007 04:29 PM

    There are some good tips for dealing with keyboard configuration, mostly for installing the VMware Tools in this thread



  • 15.  RE: Fusion suddenly ignoring keyboard input

    Posted Dec 09, 2007 12:16 PM

    I am running Leopard (OS X 10.5.1) on a MacBook Pro 15". I found that XHUB created the same problems with VMware Fusion 1.1 where I had lost keyboard input in all Fusion client sessions. Quiting XHUB solved the problem.

    My thanks to the community for helping me solve this problem - quickly.



  • 16.  RE: Fusion suddenly ignoring keyboard input

    Posted Jan 29, 2008 09:27 AM

    Also running 10.5.1, the problem was caused by Last.fm.

    Thanks for the terminal command, I would have never found the cause without it!



  • 17.  RE: Fusion suddenly ignoring keyboard input

    Posted Jun 12, 2008 04:34 PM

    I am getting below output once i ran the command in Mac OS terminal.

    Please do let me know which application cause keyboard issue in VM.

    ps auxwww | grep 302

    vnb 302 0.0 0,8 440364 16152 ?? S 8:21pm

    0:00.81 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder -

    psn_0_40970

    vnb 358 0.0 0,0 599820 464 s000 S+ 8:27pm 0:00.00

    grep 302

    Regards,

    Silica V.



  • 18.  RE: Fusion suddenly ignoring keyboard input

    Posted Dec 15, 2008 11:18 PM

    I had this issue as well.Just used the console cmd "jpoyser$ ioreg -l -w 0 | grep SecureInput" to troubleshoot it & fix it. Turns out FIREFOX 3 was the culprit

    I am using Mac OSX 10.;5.5. & I am using WinXP 32 SP3 in a VMWare Fusion 1.1.3 instance. Occaisionally, I had the same problem where WinXP would suddenly start refusing to accept my keyboard input & would give me the "boing" error sound as if I was typing with focus outside the VMware window. My mouse input worked and I could call up the Microsoft On Screen Keyboard and input text that way.

    Restarting the VMWare instance & even rebooting the whole Mac didn't seem to cure the issue.

    When I read the solution posted in this thread - I didn't think it would apply since I shouldn't be using anything requiring Secure input. But when I ran the command below - I found this:

    $ ioreg -l -w 0 | grep SecureInput

    | "IOConsoleUsers" = ({"{color:#ff0000}kCGSSessionSecureInputPID"=141,"kCGSSessionLoginwindowSafeLogin"=No,"kCGSSessionAuditIDKey"=0,"kCGSessionLoginDoneKey"=Yes,

    "kCGSSessionSystemSafeBoot"=No,"kCGSSessionOnConsoleKey"=Yes,"kCGSSessionUserIDKey"=501,"kSCSecuritySessionID"=8499344,"kCGSSessionUserNameKey"="*****",

    "kCGSSessionGroupIDKey"=20,"kCGSSessionConsoleSetKey"=0,"kCGSSessionIDKey"=256,"kCGSessionLongUserNameKey"="**** ******"})

    $ ps -ef | grep 141

    501 141 103 0 0:16.34 ?? 1:18.91 /Applications/Firefox.app/Contents/MacOS/firefox-bin -psn_0_86037

    When I closed down Firefox - and restarted the VMWare instance - the keyboard responded fine in WinXP. Then I restarted Firefox - all good. As someone else noted - as long as VMWare is started BEFORE Firefox - everything seems to be fine.

    Hope this helps someone else!



  • 19.  RE: Fusion suddenly ignoring keyboard input

    Posted Mar 25, 2008 07:25 PM

    Same problem! I'll try Last.FM... (but there's more than Last.FM because I just downloaded Last.FM yesterday and was having the same prob before!)

    Thanks guys

    EDIT: Shutting down Last.FM fixed it! Still kinda "dumb" that I can't use Last.FM with it... I guess I'll run it inside the VM for now... :|

    EDIT2: Opening the problematic app AFTER Fusion is loaded won't cause the problem... Last.FM works if you launch the VM first...