View Only
  • 1.  Windows 10 Xbox app

    Posted Jul 17, 2016 03:45 PM


    I have Fusion running on an El Capitan iMac, with Windows 10 installed.

    I am trying to connect to my Xbox One via the Xbox app.

    The Xbox does not show up on the scan. Sometimes, but not always, I am able to connect by inputting the IP address of the Xbox.

    Both the iMac and the Xbox are connected to the same 5GHz network (which has a separate name from the 2.4GHz network).

    I have a Toshiba laptop running Windows 10 which shows the Xbox on scan and connects without problem, so I am confident that the Xbox and network are set up okay.

    Any solutions to solving this problem under Fusion?



  • 2.  RE: Windows 10 Xbox app

    Posted Jul 19, 2016 03:16 PM

    Just an update, as I have made some progress.

    I found that the 5GHz connection was causing more problems than 2.4GHz and so have been working under that network.

    I have been able to connect to the Xbox and the app reports the "Now Playing" correctly. Whilst streaming if I press the "Go Home" button in app, the Xbox does go home. I can then use my Xbox controller, plugged into the iMac via USB, to control the Xbox. Whilst streaming I can hear audio, but have no video (just the dimmed app). If I "Test Streaming" everything comes back good.

    Making progress, but still no success.

  • 3.  RE: Windows 10 Xbox app

    Broadcom Employee
    Posted Jul 19, 2016 06:01 PM

    Are you on NAT or Bridged?

    You should have the VM on Bridged mode so it's on the same network layer as your Mac and Xbox.

  • 4.  RE: Windows 10 Xbox app

    Posted Jul 20, 2016 08:13 AM

    Hi Mikero and thanks for the response.

    How do I check this? I cannot see anything under the VM Settings.

    Also, by way of further update - I have identified the video problem - it is the VM Tools video driver - If I uninstall it and just use the basic Microsoft driver, I have video.



  • 5.  RE: Windows 10 Xbox app
    Best Answer

    Broadcom Employee
    Posted Jul 20, 2016 10:27 PM
      |   view attached

    VM Settings > Network or from the main toolbar. The icon is like " <--> "

  • 6.  RE: Windows 10 Xbox app

    Posted Jul 21, 2016 08:47 AM

    Just to provide an update, in case anyone else has similar problems to me:

    1. Switching from NAT to Bridge Mode (as recommended) solved the connection problem.

    2. The graphics problem (audio but no video) appears to be due to Retina Display and was solved by unchecking "Use full resolution for Retina display" in the Settings -> Display section of VMWare Fusion.

    Thanks for the assistance that has been provided.