View Only

VAMI backup fails due to vTSDB and vSTATS not starting

  • 1.  VAMI backup fails due to vTSDB and vSTATS not starting

    Posted Apr 09, 2024 08:06 PM

    When I attempt to backup the vCenter server via VAMI, I get an error message that says " Invalid vCenter Server Status: All required services are not up! Stopped services: 'vtsdb, vstats'. I tried starting both of those services through VAMI and when using the shell command "system-control --start vtsdb" & "system-control --start vstats". I know vstats is dependent on vtsdb, and tried starting that first, but I receive an error that it will not start. Logs don't really tell me anything either. I located the vtsdb start script located in /usr/lib/vmware-vtsdb/scripts/ and tried starting it there as well. When I run the vtsdb start script with the vtsdbuser account, I receive the following error: 
    FATAL: database files are incompatible with server

    DETAIL: The data directory was initialized by PostgreSQL version 13, which is not compatible with this version 14.8 (VMware Postgres 14.8.0-21922868 release). 

    I navigated to /usr/pgsql/ and I have versions 10, 13, and 14. I read somewhere not to upgrade specific packages on the server, as it could corrupt everything, especially a database. 

    I am running vsphere client version

    Any thoughts?