View Only
Expand all | Collapse all

VMWare Tools install hangs

  • 1.  VMWare Tools install hangs

    Posted Dec 12, 2008 04:17 AM
      |   view attached

    I'm running XP SP3 in Fusion 2.0.1 (128865) on a MacBook OSX

    After upgrading the vm from Fusion 1 to Fusion 2 was prompted to install VMWare Tools again.

    When installing it hangs immediately after installing the VMXNet drivers - looks like it has just tried to install HID1 of 3 hard drives.

    Any ideas? Have attached install logs.



    vminst.zip   125 KB 1 version

  • 2.  RE: VMWare Tools install hangs

    Posted Dec 12, 2008 05:07 AM

    Did you reboot the Virtual Machine and try again?

  • 3.  RE: VMWare Tools install hangs

    Posted Dec 12, 2008 05:24 AM

    When I reboot the vm looks OK and seems to be running fine.

    Still said Install VMware Tools (though doesn't say VM Tools is out of date any longer) in the Fusion Virtual Machine menu so I did... and it hangs in the same place again.

    So I Task Manager kill the Tools install, reboot and again it all looks fine.

    The XP vm still seems usable but just concerned if there will be problems at some stage since the Tools install did not finish (has never finished in fact)

  • 4.  RE: VMWare Tools install hangs

    Posted Dec 12, 2008 05:52 AM

    I'm sorry I can't help you with why its hanging however I can tell you that from the log files VMware Tools are not properly or successfully installed. Hopefully one of the VMware employees will take a look at the logs and offer something to try.

    The following is missing from the vmmsi.log file: "Product: VMware Tools -- Installation operation completed successfully."

  • 5.  RE: VMWare Tools install hangs

    Posted Dec 12, 2008 08:28 AM

    Uninstall Tools and delete "VMware Tools" folder in Guest OS and reboot the system twice and try to install Tools.


    Silica V.

  • 6.  RE: VMWare Tools install hangs

    Posted Dec 12, 2008 10:41 AM

    As Silica V has suggested, uninstalling and reinstalling VMware Tools might help in this.

    Follow the below instruction for clean installation of VMware Tools.

    A) Uninstall VMware Tools:

    1) Power on the Virtual Machine

    2) Go to Control Panel

    3) Open Add/Remove Programs

    4) Uninstall VMware Tools

    5) Delete the VMware Folder from c:\Program Files

    6) Restart the Guest OS

    B) Reinstall VMware Tools:

    1. Launch Fusion

    2. Go to “Virtual Machine”

    3. Click on “Install VMware Tools”

    4. This will take you to installation wizard

    5. Follow the screen for installation

    6. Reboot the VM after Installation of VMware Tools

  • 7.  RE: VMWare Tools install hangs

    Posted Dec 13, 2008 10:36 AM

    I don't have VMWare Tools listed in the Add/Remove (even with 'Show Updates' checked)...

    I've looked in the Program Files folder but can't see anything like an uninstall file to run manually.

    Is there another way to uninstall?

  • 8.  RE: VMWare Tools install hangs

    Posted Dec 13, 2008 10:37 AM

    Also tried the VMWare Tools icon in the taskbar but no uninstall option there...

  • 9.  RE: VMWare Tools install hangs

    Posted Dec 13, 2008 10:58 AM

    1. I ran VMware Tools setup again and chose to not actually install any of the features so the install did not hang trying to set up the HID1. Now it finished I saw the Add / Remove entry.

    2. Uninstall WMware Tolls successfully

    3. Deleted the Program Files VMware folder (though had to stop some vmware processes first using Task Manager before it would let me delete the folder).

    4. Rebooted the vm twice

    5. Ran the VMware Tools install again.

    6. Install hangs in exactly the same place :smileysad:

    Any ideas? I've run out myself :smileyhappy:

  • 10.  RE: VMWare Tools install hangs

    Posted Feb 02, 2009 02:20 PM

    Hello. I am having the same exact problem except I am starting with a clean VMWare Fusion 2.01 install. The VMWare tools installation hangs completely sitting there for an hour if I let it. Is there any real solution to this? The uninstall/reinstall method does not work as VMWare Tools have never been successfully installed.

  • 11.  RE: VMWare Tools install hangs

    Posted Feb 02, 2009 03:28 PM

    I was able to solve this problem by opening the Windows task manager and killing a lot of processes and then installing the VMWare tools. I have a pretty minimalistc install but I am not sure which process was causing the problem.

  • 12.  RE: VMWare Tools install hangs

    Posted Feb 09, 2009 05:20 AM

    I also solved it. See here:[m-1165636]

  • 13.  RE: VMWare Tools install hangs

    Posted Mar 18, 2009 05:45 PM

    I have the same problem, but none of these options is working for me.

  • 14.  RE: VMWare Tools install hangs

    Posted Mar 18, 2009 10:12 PM

    I just downloaded Fusion 2.0.2 and upgraded.

    It again said the VM Tools was out of date so I upgraded it.

    This time no problems and all works fine now.

  • 15.  RE: VMWare Tools install hangs

    Posted May 12, 2009 03:54 PM

    I started with VMware Fusion 2.0.4 and have this issue. I have tried everything listed in this thread, but VmTools still hangs. This is really frustrating. Any new ideas anyone? Is anyone else seeing this on 2.0.4?

  • 16.  RE: VMWare Tools install hangs

    Posted May 12, 2009 04:11 PM

    I have had not had any problems installing VMware Tools in any of the OSes I use with the Supported OSes while using Fusion 2.0.4.

    If your having a problem with Windows XP then I would uninstall VMware Tools from Start > Control Panel > Add or Remove Programs > VMware Tools and then use the utility in the following following Microsoft KB Article and then try to install VMware Tool again.

    Description of the Windows Installer CleanUp Utility

  • 17.  RE: VMWare Tools install hangs

    Posted May 12, 2009 07:26 PM

    I don't see VMware tools in the control panel or even when clicking the icon(It does get installed to some extent, but hangs towards the end. The "Installation Finished" window does not show up. That said, I finally got it installed using a suggestion you gave on another thread:


    If you go into My Computer (Windows Explorer) and look at the CD/DVD Drive can you double-click to open it and see the setup.exe and then if so double-click the setup.exe?

    If not you may have to manually mount the VMware Tools window.iso file...

    At this point go ahead and select Cancel VMWare Tools Installation from the Virtual Machine menu and then shutdown, not suspend the Virtual Machine. (You could do this without shutting down the Virtual Machine however under the circumstances it may be best to just shutdown, make the following changes and continue on.)

    In the CD/DVD Settings sheet select the Use disk image: radio button then in click the list box and select Choose... then point it directly to the VMware Tools Windows ISO file ("/Library/Application Support/VMware Fusion/isoimages/windows.iso") and then start the Virtual Machine and DO NOT SELECT "Install VMware Tools" from the Virtual Machine menu! Just go straight to the CD/DVD-ROM Drive in Windows and execute the setup.exe.

    You may also want to look at: VMware Fusion menu bar > Help > VMware Fusion Help > Managing Virtual Machines > Configuring the CD/DVD Drive


    Just to be sure that this was indeed the issue, I created a new VM from scratch(see note ** below) and tried to install the VM Tools from the pull down menu and again it hangs. I then tried the above solution, and it installed to finish. So there is still this issue, at least from what I have experienced, with Windows XP, WMware Fusion 2.0.4 and the installation of the VMtools from the pull down menu. The only way out seems to be installing it from the CD-ROM drive.

    **Note - all the VMs I was creating were VMs from converted physical machines. This is where I was seeing this problem. Maybe it does not occur when you just create a VM thats not a converted physical machine. I haven't tried that.

    Thanks for your reply and your earlier solution.