View Only

ThinPrint driver seems to remove printer control codes

  • 1.  ThinPrint driver seems to remove printer control codes

    Posted Jul 29, 2011 01:40 AM

    I am having a printing problem that is a regression of a problem discussed originally at http://communities.vmware.com/message/1253758#1253758, and in a much longer thread which I can no longer find.

    Here is the issue: I have an old DOS application running in an XP VM that sends printer control codes. When used with a ThinPrint printer, the control codes just print as normal text and thus have no effect to control the printer. I previously solved this program with a kludge involving setting up a USB printer in the VM, enabling it to be shared, and then a "net use" to map LPT1 to the shared printer.

    Please note: a lot of time was wasted by people advising me not to use a USB printer, for various reasons. However, those discussions missed the point the only by setting up the USB printer was I able to successfully send the printer control codes.

    In any case, I solved the problem via the kludge, which is described in detail in the post referenced in the first sentence above.

    However, I have now moved the USB printer connected to the Mac host to a Time Capsule. This will allow easier network printing. However, by losing the USB printer on the host, the kludge fails as the mapping no longer exists.

    If I knew how to send printer control codes through the ThinPrint driver, I think it would solve the problem. Obviously control codes work, because all the normal Windows apps certainly are able to do so. However, in sending them the DOS command line, they simply print as text.

    Does anyone know how to do this?