Fusion

 View Only
Expand all | Collapse all

macOS Catalina issue [beta]

crould

crouldJun 06, 2019 06:10 AM

Hs0willowdale

Hs0willowdaleJun 09, 2019 01:07 AM

insightdesign

insightdesignJul 17, 2019 03:38 AM

  • 1.  macOS Catalina issue [beta]

    Posted Jun 04, 2019 02:25 AM

    Hello.  I installed the new macOS 10.15 beta today, and loaded fusion to find that my Windows 7 VM boots up and runs just fine, but only shows a black screen. I can see it in the library and even use it by typing, moving the mouse around in the black screen, and watching in the library but that's all. Has anyone experienced this before? I've tried reinstalling Fusion, to no avail. It also doesn't show anything during post/boot, so it's not a video driver issue I don't think.

    - Accelerate 3D Graphics is NOT checked.

    - I receive NO error messages.



  • 2.  RE: macOS Catalina issue [beta]

    Posted Jun 04, 2019 10:27 AM

    From the thumbnail in VM Library, I see the Win7 VM has been booted up.

    Could you send Ctrl_Alt_Delete to the guest to see if the key event works?

    PS: After install Fusion, have you ever restarted host OS?



  • 3.  RE: macOS Catalina issue [beta]

    Posted Jun 04, 2019 04:07 PM

    Yeah as I was saying, everything works just fine when I send key/mouse strokes to the blank screen it appears in the library window. Just can't see it in the VM itself.

    I've restarted 30 times.



  • 4.  RE: macOS Catalina issue [beta]
    Best Answer

    Posted Jun 05, 2019 09:53 AM

    Hi wtfmatt,

    Could you please try these steps:

    1. Open System Preferences -> Security & Privacy.

    2. Select Screen Recording in the list.

    3. Click the lock and input password to make change.

    4. Make sure the checkbox for "VMware Fusion" item is checked. If not, check it.

    5. Restart Fusion.



  • 5.  RE: macOS Catalina issue [beta]

    Posted Jun 06, 2019 06:10 AM

    Mine is nothing there



  • 6.  RE: macOS Catalina issue [beta]

    Posted Jun 06, 2019 10:20 AM

    To add Fusion to the list, you can do this:

    1. Open System Preferences -> Security & Privacy -> Privacy.

    2. Select Accessibility in the list on left side, click "+", select "VMware Fusion.app" in Applications to add Fusion into the Allow the list and check the checkbox.

    3. Launch Fusion, create a fake VM (I'm not sure if opening an existing VM has the same effect).

    (File -> New, select "Create a custom virtual machine", select any operation system, press "Continue" several times then "Finish", Save the VM, it will be powered on automatically)

    Then the following dialog will pop up, click Open System Preferences, it will be added to the list.

    PS: If the message never pop up on your mac, try to enable Full Disk Access for Fusion. On one of