Fusion

 View Only
  • 1.  Moving mouse to screen edge loses focus on VM

    Posted Nov 10, 2007 12:46 PM

    I've noticed this problem ever since installing 1.1RC.

    When moving the pointer to the edges of the screen in a full-screen session causes the focus to the changed from the VM.

    I hope this will be fixed in the official release.



  • 2.  RE: Moving mouse to screen edge loses focus on VM

    Posted Nov 10, 2007 01:13 PM

    This usually happens when the VMware Tools are not installed properly in the guest, or are you gaming in the VM? If you are gaming check out the Customizing the virtual machine's mouse settings for playing games in the Fusion Release Notes



  • 3.  RE: Moving mouse to screen edge loses focus on VM

    Posted Nov 10, 2007 02:20 PM

    I am not gaming, just running a full-screen Linux application with a right-hand side scroll bar. When I overshoot the scrollbar, the focus goes out of the VM.

    I am running the latest VMware Tools included with Fusion 1.1RC



  • 4.  RE: Moving mouse to screen edge loses focus on VM

    Posted Nov 10, 2007 02:27 PM

    Just curious as to the exact distro and version, e.g. Ubuntu 7.10 (with Xorg 7.3 requires some tweaking). A solid solution to your issue is this suggestion in the gaming section of the Rel Notes:

    To customize the virtual machine's mouse settings for playing games (ignore this), use TextEdit to make the following changes while the virtual machine is powered off:

    In your home directory, add the following line to the end of the file ~/Library/Preferences/VMware Fusion/preferences:

    pref.motionUngrab = "FALSE"



  • 5.  RE: Moving mouse to screen edge loses focus on VM

    Posted Nov 10, 2007 03:16 PM

    This solves the problem, but now I can't use Unity for my Windows XP VM... the behaviour definitely changed since Fusion 1.0, which worked fine.

    IMHO, I don't think a full-screen VM session should be subject to the same "rules" as windowed VMs.

    I was running Ubuntu 7.10 with Fusion 1.0 and had no issues. Simply installing 1.1RC introduced this problem and loss of the use of my scroll wheel (which I fixed by editing /etc/X11/xorg.conf)

    Thank you for your help.



  • 6.  RE: Moving mouse to screen edge loses focus on VM
    Best Answer

    Posted Nov 10, 2007 03:23 PM

    You didn't mention Windows before :smileywink:

    Do you have the menu artifacts in Ubuntu 7.10? This is one indication part of the VMware Tools for your guest are not set right. It is a known issue for Ubuntu 7.10. The solution to that problem and possibly the mouse ungrabbing is in this thread:



  • 7.  RE: Moving mouse to screen edge loses focus on VM

    Posted Nov 10, 2007 03:47 PM

    Yup, that solves it. I backed out the change you proposed and used the recommendation in the other thread. Seemingly works perfectly now!

    Thanks!