Fusion

 View Only
  • 1.  Macbook Pro and bridge NIC settings

    Posted May 15, 2009 04:27 PM

    Hi Everyone,

    I have a 15 inch macbook pro with latest version of OS X then I have installed newest version of VMware Fusion (2.0.4) on that machine. Also I have copy of Windows XP Pro as a VM in that machine.

    Here is the problem with this VM:

    I can't get an IP address whenever I use the bridge setting for my virtual NIC but using NAT setting will get me an IP address and I can get to different sites and other network resources.

    Can anyone suggest any solution to solve this problem?

    Thanks,



  • 2.  RE: Macbook Pro and bridge NIC settings

    Posted May 15, 2009 05:11 PM

    I'm assuming you are trying to get an IP address with C:\> ipconfig/release & ipconfig/renew or something along those lines? If that is the case, what sort of error messages are you getting?

    Have you tried bridged mode on more than one network? From other threads I've read apparently some routers will not assign more than 1 IP address to a physical MAC address / NIC. If you are encountering that situation then one would expect DHCP to work fine in NAT mode, but not in Bridged mode. If I remember correctly, some Wireless routers are more likely to not hand out more than 1 IP address through the Mac's NIC card than wired routers.

    Your easiest trouble shooting is probably to join another network and see if Bridged mode works there (then it is the behavior of the first network that is stopping you).

    Once or twice in the last year and a half I have encoutered this behavior with wireless networks, but in most cases just restarting the VMs and the Mac cleared it up.



  • 3.  RE: Macbook Pro and bridge NIC settings

    Posted May 15, 2009 06:14 PM

    Ok, this is strange, today when I rebooted my VM and now it is pulling a dhcp address in bridged mode.

    Yesterday, I tried rebooting, release/renew ip address (using wired connection) but noting seemed to work but today it is completley different story. I have tested my VM multitple times (rebooting, changing thru different network connection types) and every time it seems to be working fine.

    The only difference between yestday and today's testing scenerio is newest version of Fusion, may be VMware has changed something and that is why it working now.

    But I do want to say thank to you for your suggestions.

    Thanks,



  • 4.  RE: Macbook Pro and bridge NIC settings

    Posted May 15, 2009 06:44 PM

    I also experience some intermittent behavior that I've never been able to isolate when / why it happens. Like I said in my earlier post maybe 3 or 4 times since Jan. 2008 I've had VMs that would not get DHCP'ed in bridged mode (at least one instance where 1 VM did and the other didn't). There did not seem to be any correlation between software updates and these occurrences.

    Another intermittent behavior I experience is sound working or not within my VMs. This intermittent behavior is independent of Windows, Fusion, or MacOS updates. Sound is not vital for my use of the Windows VMs, and I have no sound so infrequently I've never expended effort to try to isolate it.

    Now that you have it working you can kind of choose how much effort you want to invest in figuring out why.



  • 5.  RE: Macbook Pro and bridge NIC settings

    Posted Aug 06, 2009 03:00 AM

    I seem to be having the same problem.

    I am trying to run ESX4i in a Fusion VM for a lab environment.

    NAT works fine, bridging does not (either when connected via copper or wifi).

    I have tried uninstalling/reinstalling Fusion, setting en1 option in boot.sh, etc, no luck.

    I'm not sure when it started failing, but it seems to have been in the last 6 months.

    Any ideas what I can check?