Backup & Recovery

 View Only
  • 1.  Veeam Backup failed with error

    Posted Mar 20, 2024 07:30 PM

    In my veeam backup replication there is a backup failed with the below error.

    "3/20/2024 1:12:19 PM :: Processing AD-DC1 Error: An error occurred while quiescing the virtual machine. See the virtual machine's event log for details. (An error occurred while saving the snapshot: Failed to quiesce the virtual machine., An error occurred while taking a snapshot: Failed to quiesce the virtual machine.)" Upon checking i found the veeam unable to create snapshot.

    So i went to vcenter and tried to start the  quiesced snapshot and i got error. Checked the VM logs in vcenter found.
    VssSyncStart' operation failed: IDispatch error #8449 (0x80042301). I have checked the VM tools service and VSS writers state everything is okay, 

     

     


  • 2.  RE: Veeam Backup failed with error

    Broadcom Employee
    Posted Mar 21, 2024 06:40 AM

    No clues about the VM, about the vSphere version, the Veeam version, or whether you have done research on the Veeam forums?

     



  • 3.  RE: Veeam Backup failed with error

    Posted Mar 21, 2024 08:11 AM

    Hi,

    it will be the post it to the Team forums as mentioned above, but I can tell you that the most problems with backup is that you have snapshots on the VM's and they to the problems. Only vCenter is an exception and for it is its special backup and restore procedure.

     



  • 4.  RE: Veeam Backup failed with error

    Posted May 18, 2024 07:14 PM

    Hey Roopeshm,

    I usually see this happen when a Windows Instance (both Virtual and Physical) have a ton of VSS snapshots, or have modified VSS snapshot configuration. For example, I saw this a few weeks ago in an environment where the IT team configured snapshots on an hourly basis, resulting in tons of VSS snapshots, causing a large amount of time needing snapshots to be processed.

    When you add in a backup application, like Veeam, timeouts can be hit due to the increased amount of time for a VSS snapshot to be processed.

    In most cases when I run in to this, if appropriate (need to verify you can), I'd remove all the VSS snapshots in the VM, check the configuration, and usually after clearing all snapshots, issues will be resolved.

    Cheers,

    Stephen




  • 5.  RE: Veeam Backup failed with error

    Posted May 20, 2024 04:37 AM
    Edited by Casey May 20, 2024 04:38 AM

    1. Verify VSS Writers State

    • Ensure that all VSS writers on the VM are in a stable state. You can check the VSS writers by running the following command in the VM's command prompt with administrative
    vssadmin list writer
    • If any VSS writers are in a failed state, try restarting the Volume Shadow Copy service and check the writers again.

    2. Check VMware Tools

    • Ensure that VMware Tools is installed and running on the VM. Sometimes, reinstalling or upgrading VMware Tools can resolve quiescing issues.
    • To reinstall VMware Tools, you can right-click on the VM in vCenter, select Guest OS > Install/Upgrade VMware Tools, and follow the prompts.

    3. Free Up Disk Space

    • Ensure there is enough free disk space on the VM for snapshot creation. Lack of space can cause snapshot and quiescing failures.

    4. Review Event Logs

    • Check the VM's event logs for any additional errors related to VSS or snapshot creation. Look under Windows Logs > Application for VSS-related errors.

    5. Check Snapshot Settings

    • Try taking a manual quiesced snapshot from vCenter to isolate whether the issue is with Veeam or VMware. Right-click the VM, select Snapshots > Take Snapshot, and ensure Quiesce guest file system (Needs VMware Tools installed) is checked.

    6. Update Veeam and VMware

    • Ensure that both Veeam Backup and Replication and your VMware environment are up to date with the latest patches and updates. Compatibility issues can sometimes cause these errors.

    7. Adjust VSS Settings

    • Sometimes, adjusting VSS settings can help. You can try changing the VSS provider in Veeam to use the system provider instead of the VMware VSS provider.
      • In Veeam, go to Backup Infrastructure > Managed Servers.
      • Right-click the affected server and choose Properties.
      • Under the Volume Shadow Copy Service section, select Use system provider.

    8. Disable Application-Aware Processing

    • Temporarily disable application-aware processing in Veeam to determine if it is causing the issue.
      • Edit the backup job in Veeam, go to the Guest Processing step, and uncheck Enable application-aware processing.

    This should do the trick for you, however if not, please post back and include as much detail as possible. 



    ------------------------------
    Love for Virtual Infrastructure!

    If my post helped, please click the thumbs up or mark as solved. I can't promise my solutions will work, but I will promise to do my best!

    VCP-DCV 8.x | VCP-DCV 6.x | CompTIA A+, Net+, Sec+, Proj+ | MCSE | MCSA | MCITP |
    ------------------------------