Fusion

 View Only
Expand all | Collapse all

Networking not working on any VMs, macOS 11 Beta

Big5ur

Big5urSep 21, 2020 07:00 AM

rjtort

rjtortSep 29, 2020 06:44 PMBest Answer

bobba84

bobba84Oct 02, 2020 05:45 AM

  • 1.  Networking not working on any VMs, macOS 11 Beta

    Posted Sep 16, 2020 04:05 PM
      |   view attached

    Running VMware Fusion 12 Pro on macOS 11 Beta, tried multiple VMs with every networking option. Get this error ->

    No idea how to diagnose this issue.



  • 2.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 16, 2020 04:10 PM

    Here is relevant VMware.log

    2020-09-16T12:02:13.181-04:00| vmx| A000: ConfigDB: Setting tools.syncTime = "FALSE"

    2020-09-16T12:02:13.189-04:00| vmx| A000: ConfigDB: Setting tools.upgrade.policy = "useGlobal"

    2020-09-16T12:02:13.202-04:00| vmx| A000: ConfigDB: Setting ethernet0.connectionType = "nat"

    2020-09-16T12:02:13.209-04:00| vmx| A000: ConfigDB: Setting ethernet0.addressType = "generated"

    2020-09-16T12:02:13.209-04:00| vmx| A000: ConfigDB: Setting ethernet0.generatedAddress = "00:0C:29:27:1B:88"

    2020-09-16T12:02:13.230-04:00| vmx| A000: ConfigDB: Setting ethernet0.virtualDev = "e1000"

    2020-09-16T12:02:13.251-04:00| vmx| I005: VNET: 'ethernet0' enable link state propagation, lsp.state = 5

    2020-09-16T12:02:13.252-04:00| vmx| I005: DictionaryLoad: Cannot open file "/Library/Preferences/VMware Fusion/config": No such file or directory.

    2020-09-16T12:02:13.252-04:00| vmx| I005: VNET: MACVNetMacosGetRealAdapterType: network type for adapter 0: 8

    2020-09-16T12:02:13.252-04:00| vmx| I005: VNET: MACVNetMacosGetVnetProperties: vnet properties: vnet=vmnet8, nat=yes, dhcp=yes (ignored), subnet=192.168.49.0, mask=255.255.255.0, firstAddr=192.168.49.1, lastAddr=192.168.49.127, isIPv6=no, IPv6Prefix=fd15:4ba5:5a2b:1008::, IPv6PrefixLen=64

    2020-09-16T12:02:13.252-04:00| vmx| I005: VNET: MACVNetPortVirtApiStartInterface: Waiting on semaphore for adapter: 0

    2020-09-16T12:02:18.253-04:00| vmx| W003: VNET: Timeout while waiting for semaphore for adapter: 0, timeoutMs=5000, waitMs=5001!

    2020-09-16T12:02:18.253-04:00| vmx| W003: VNET: MACVNetPortVirtApiStartInterface: start handler not called for adapter: 0!

    2020-09-16T12:02:18.253-04:00| vmx| W003: VNET: MACVNetPortVirtApiStartInterface: Failed to create interface for adapter: 0, handlerStatus: 1001

    2020-09-16T12:02:18.255-04:00| vmx| I005: VNET: MACVNetPort_Connect: Ethernet0: can't start virtual interface

    2020-09-16T12:02:18.256-04:00| vmx| I005: Msg_Post: Error

    2020-09-16T12:02:18.256-04:00| vmx| I005: [msg.vnet.connectvnet] Could not connect 'Ethernet0' to virtual network '/dev/vmnet8'. More information can be found in the vmware.log file.

    2020-09-16T12:02:18.256-04:00| vmx| I005: [msg.device.badconnect] Failed to connect virtual device 'Ethernet0'.

    2020-09-16T12:02:18.256-04:00| vmx| I005: ----------------------------------------



  • 3.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 16, 2020 04:39 PM

    I have the same error, but with VMware Beta....and Big Sur Beta 6

    You have that problem with the recent public VMware 12? or with the VMware beta version?



  • 4.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 16, 2020 04:49 PM

    Was using the Fusion beta, but just purchased the Fusion 12 Pro version hoping it would fix the problem. It did not.



  • 5.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 16, 2020 05:29 PM

    Did you tried from stretch ?

    Install VMware 12 (public), then Mac os Big Sur beta?

    I have the same problem, and I am thinking to do from stretch...



  • 6.  RE: Networking not working on any VMs, macOS 11 Beta

    Broadcom Employee
    Posted Sep 16, 2020 06:06 PM

    We're investigating, but all indications are pointing to a regression in macOS itself.

    We've reported to Apple and are actively working on it.



  • 7.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 16, 2020 06:21 PM

    finally we have as answer form VMware! Thanks

    there are many discussions about this...and many customers paid for the fusion 12 (like me) and until now we did not know what happen

    we hope the confirmation from VMware when you get an answer from apple.



  • 8.  RE: Networking not working on any VMs, macOS 11 Beta

    Broadcom Employee
    Posted Sep 16, 2020 06:58 PM

    =D

    Our apologies on that... the question has come up in many places and we've answered it where we saw it, but there's a lot going on right now as one could imagine :smileywink:



  • 9.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 16, 2020 07:08 PM

    Is there a workaround? The known issues from VMware indicates problems with NAT, however bridged, NAT, and custom interfaces all give the same error.

    I understand that macos 11 is beta but im sitting on some big projects because none of my vms have a network connection.



  • 10.  RE: Networking not working on any VMs, macOS 11 Beta

    Broadcom Employee
    Posted Sep 16, 2020 08:48 PM

    Unfortunately we haven't found one yet... We're still trying to figure out the pattern of systems affected by the bug.

    For example, none of my machines have it, but the engineering lead (manager) has it on his testing rig, and we've both upgraded to each beta (tho I think I started with a fresh format when I installed Beta 1)

    We have Radar's filed with Apple.



  • 11.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 17, 2020 05:47 PM

    I'm experiencing the same issue of no network in Windows 10 using Fusion Player 12. I'm running Big Sur public beta 20A5364e.

    I believe I had network using the tech preview of fusion and the previous beta of Big Sur.

    Here is the screenshot and the pastebin of my log file



  • 12.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 17, 2020 06:42 PM

    Still not working with macOS Big Sur Beta 7 20A5374.  (MacBook Pro 16" 2019)

    It would seem Apple has ignored VMware's feedback or this problem won't be an easy one to solve.  I'll keep trying with each Big Sur Beta and report back here.



  • 13.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 16, 2020 07:55 PM

    I can confirm this is problem with Parallels Desktop 16 also and Beta 6 :/ Seems to be something Apple has done.



  • 14.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 21, 2020 07:00 AM

    I have the same error



  • 15.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 22, 2020 07:43 PM

    FYI, still not working in BigSur beta 8 (20A5374i) that released today.



  • 16.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 22, 2020 09:48 PM

    If you all haven't already, I would recommend submitting a report via Apple's feedback assistant. I've been assuming that this was a VMWare issue and waiting for them to fix it. With things still being broken and not a peep out of VMWare except to blame it on a regression in Big Sur, I decided to submit my own report today. Looks like Apple reviewed my comments and it now shows under "Recent Similar Reports: Less than 10". Which leaves me to wonder if everyone else is doing what I was, waiting on VMWare...so Apple too is assuming it's a VMWare issue and not looking into it any further.

    Just my 0.02$...Take it for what it's worth. :smileywink:



  • 17.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 23, 2020 12:32 AM

    I submitted a feedback to Apple because this regression has broken a program that I'm developing. (I supplied a simple test case as well.) I presume that Parallels has also submitted a report.

    I would've expected reports from major developers like VMware and Parallels to bump the priority on this issue.



  • 18.  RE: Networking not working on any VMs, macOS 11 Beta

    Broadcom Employee
    Posted Sep 23, 2020 05:50 PM

    I would've expected reports from major developers like VMware and Parallels to bump the priority on this issue.

    We did. We just don't control when Apple ships said fixes.



  • 19.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Sep 23, 2020 05:54 PM

    The solution here resolved the problem for me:

    Re: No Ethernet Connection VMware Fusion 12 macOS Big Sur Beta 6



  • 20.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Jan 05, 2021 05:33 AM

    still the same issue Could not connect 'Ethernet0' to virtual network 'vmnet4'.



  • 21.  RE: Networking not working on any VMs, macOS 11 Beta
    Best Answer

    Posted Sep 29, 2020 06:44 PM

    Fixed in macOS Big Sur Beta 9 version 20A5384c.



  • 22.  RE: Networking not working on any VMs, macOS 11 Beta

    Posted Oct 02, 2020 05:45 AM

    Not for me it's not :smileysad: