VMware Workstation

 View Only
  • 1.  VMware Workstation 16 very slow on Windows 11

    Posted Aug 10, 2022 04:55 PM

    Hi there,

    first of all, my Host and VM Setup

    Host: Windows 11 Pro (fresh install, nothing except drivers), AMD Ryzen 7 4800H (8 Cores, 16 Threads) :: 64GB RAM

    Guest: Windows 10 Enterprise (existing VM) 8 Cores :: 32GB RAM

    I previously had Archlinux on my Host and with that, and VMware Workstation, the VM run at pretty much native speed. I could put it into Fullscreen and not even notice, its an VM. I could watch YouTube videos in 4K fluent, games worked fine, everything just fine.

    But because there is no Unity Mode on Linux, i wanted to use Windows 11 on the Host so i could use the Unity Mode on Windows 10.

    Now the Windows 11 Hosts works fine, everything is performing as it should but VMware is extremely slow. The application itself (opening the VM settings takes like 5 Seconds or so) but also the VM.

    When i start the VM, it takes roughly 15 seconds until the BIOS shows up and another 30 Seconds until Windows is bootet.

    For comparison, the whole boot process took 15 seconds in total on the Linux host.

    I am using the exact same VM i used in Linux, when opening it he asked me if i copied it or moved it, i said moved and thats it.

    And the VM itself is very slow. Moving windows around is lagging, watching YouTube videos is pretty much impossible and so on.

    I read that some issues appear on Hyper-V enabled hosts, but this is not an Hyper-V Enabled host (Hyper-V is not installed)

    I already changed the setting that VMware is putting the VM completely into RAM and not using the page file which helped a bit, but its still a much worse performance than on the Linux host.



  • 2.  RE: VMware Workstation 16 very slow on Windows 11

    Posted Aug 10, 2022 05:05 PM

    Please attach a vmware.log file from the vm.

    --
    Wil



  • 3.  RE: VMware Workstation 16 very slow on Windows 11

    Posted Aug 10, 2022 05:11 PM
      |   view attached

    Hi there,

    thank you for your fast reply!

    This is the result of one Boot + Shutdown directly after the successfull boot. I noticed that the Windows loading animation bubbles, the circle, constantly change speed. They are sometimes slow, but sometimes they circle with the 10x speed or so.

    Attachment(s)

    log
    vmware.log   195 KB 1 version


  • 4.  RE: VMware Workstation 16 very slow on Windows 11
    Best Answer

    Posted Aug 10, 2022 05:20 PM

    Hi,

    Your host is running in user level mode (a.k.a. under a hypervisor)

    2022-08-10T17:07:16.875Z In(05) vmx Monitor Mode: ULM

     

    ULM is User Level Mode a.k.a. Hyper-V

    CPL0 is ring 0, a.k.a. no hypervisor

    https://communities.vmware.com/t5/VMware-Workstation-Pro/MikroTik-RouterOS-boot-speed-is-drastically-slow/m-p/2291457/highlight/true#M137161

    In order to turn off Hyper-V mode, run the following command at the host in windows command-line with Administrator privileges:

    bcdedit /set hypervisorlaunchtype off

    Reboot the system to activate your changes.

    If you want to go back to Hyper-V mode again, then you can enable it like this:

    bcdedit /set hypervisorlaunchtype auto


    See also:

    Note that you also might have to disable Memory Integrity.

    Windows Security -> Device Security -> Core Isolation details

    Don't forget to reboot the host after making any of these changes.

    --

    Wil



  • 5.  RE: VMware Workstation 16 very slow on Windows 11

    Posted Aug 10, 2022 05:30 PM

    Thank you so much, the performance is back to normal.

    May i ask you if i did something wrong during the setup? Or did i miss something? Should i have read the Manual?^^

    Because Hyper-V is not installed (i just checked again, everything is unchecked in the Windows Features section) i would not have guessed any relation to that.



  • 6.  RE: VMware Workstation 16 very slow on Windows 11

    Posted Aug 10, 2022 05:34 PM

    No, you did everything correct.

    This is just Microsoft being a PITA by not being clear when they enable a hypervisor on your behalf.

    --
    Wil



  • 7.  RE: VMware Workstation 16 very slow on Windows 11

    Posted Feb 17, 2023 06:13 PM

    I typed this into the run command and rebooted my laptop.  i opened up the vmware.log again and it still says Monitor Mode: ULM.  
    Is the log file update every time VMWare is opened, because maybe I'm seeing the previous log before I did the bcdedit.



  • 8.  RE: VMware Workstation 16 very slow on Windows 11

    Posted Feb 17, 2023 06:19 PM

    It normally updates every time.

    Easy enough to check, just rename the vmware.log file and restart the VM.

    Most likely you missed one of the other steps.

    edit: also please note that the log file is time stamped, many lines have a datetime in the first column.
    So that would be another way to check.

    --
    Wil



  • 9.  RE: VMware Workstation 16 very slow on Windows 11

    Posted Nov 22, 2022 11:20 AM

    This also seemed to have fixed my issue. 

    I did 

    bcdedit /set hypervisorlaunchtype off

    And the performance increased again.

    The problem with this is tho, it makes WSL2 unusable. Is there any way to work around this? To be able to have both, VMWare working and WSL2?

    Thanks! 



  • 10.  RE: VMware Workstation 16 very slow on Windows 11

    Posted Jun 13, 2023 06:41 AM

    Although I followed all those steps my VM still ran in ULM. After a while I saw that the windows feature Windows Hypervisor Platform was installed. After uninstalling and rebooting it worked for me. Please note that in my case all the network settings in the virtual network editor were lost and had to be setup again (took me just 5 minutes).

    Now the VM saves data in 3 seconds instead of 3 minutes!