Fusion

 View Only
Expand all | Collapse all

vmware-vmx 100% cpu usage...

  • 1.  vmware-vmx 100% cpu usage...

    Posted Oct 08, 2013 02:49 PM

    Hi All.  I have a 13" retina MBP with 2.9 GHz i7 and 8GB of ram.

    I'm running 10.8.5 with all updates, and Fusion 6.0.1

    I have a Windows XP 32-bit SP3 VM.

    If I run this VM from the OS X boot drive (ie. the SSD that comes with the 13" rMBP), everything is fine.

    However, if I copy this VM over to a LaCie 32GB Rugged USB 3.0 key, vmware-vmx consumes 100% cpu usage and the VM is basically unuseable.

    If I copy it back to the Mac boot drive, all is well.

    So it's clear what the issue is on a high level -- I want to know what the root cause is on a low-level so it can be fixed, or there can be some workaround possibly...

    I have three of these USB 3.0 LaCie 32GB Rugged Keys, and it happens on all three of them.

    Any ideas?  The entire reason I bought these keys were to run / store virtual machines on them.

    Their read / write speeds are very impressive on these Rugged Keys since they are USB 3.0.

    They're all formatted as ExFat -- but I tried reformatting one to HFS+ and it made no difference, the issue is still there.

    Is there some kind of hardware incompatibility with these keys and VMWare fusion?



  • 2.  RE: vmware-vmx 100% cpu usage...

    Posted Oct 09, 2013 06:33 AM

    Hi nkustreba,

    Thanks for using Fusion 6.0.1

    I also encountered cpu-usage 100%, but only when install or upgrade the VM tools.

    After installation finished, the cpu-usage down and vm works properly.

    But my USB key is format as MS-DOS(Fat 32). So I suggest you format your key as MS-DOS(Fat 32) via Disk Utility, hope it will be a help for you.



  • 3.  RE: vmware-vmx 100% cpu usage...

    Posted Oct 09, 2013 01:33 PM

    Hi Leo-Wang, thank you for responding to the thread I posted.

    Fat32 is a no-go though...it only supports a maximum of 4GB file sizes.

    My "Windows XP Professional.vmwarevm" file is 17GB...so unfortunately, I can not even test this.

    I use these keys to store other (large) files also, so even if it did work, it would not be an overall solution / workaround :|



  • 4.  RE: vmware-vmx 100% cpu usage...

    Posted Oct 10, 2013 04:39 AM

    Hi nkustreba,

    I have tested it with my environment, Fat32 has limitation for 4GB file size, but this is only apply to single file,

    our **.vmwarevm is just like folder in Windows, so it doesn't have this limitation, I have copy 7GB to USB key and launch vm successfully. It should work...



  • 5.  RE: vmware-vmx 100% cpu usage...

    Posted Oct 10, 2013 01:22 PM

    Hi Leo; I apologize, I should have clarified; I use the keys to store *other* files that are not VMWare related, that are larger than 4GB.  So using a FAT32 filesystem on the keys is not a solution.

    Regardless, I will test FAT32 right now just to see if it will work and the behavior changes.

    EDIT: Changed to Fat32 (MSDOS) just to test, the issue remains. 

    Sigh.

    Maybe when 8.1 is officially released I'll start a new VM and get rid of this XP one.

    Still though, I wish you guys would come up with a solution where you recognize that vmware-vmx is using so much CPU for a long period of time, and present a dialog box to the user saying that there's something most likely bad going on.



  • 6.  RE: vmware-vmx 100% cpu usage...

    Posted Oct 11, 2013 12:29 AM


  • 7.  RE: vmware-vmx 100% cpu usage...

    Posted Oct 11, 2013 02:07 AM

    Thanks GSZoniec, but I have all the updates installed, and that microsoft KB does not apply to Windows XP.

    I found another thread once having something to do with the thunderbolt to ethernet adapter or wifi adapter bridging causing the high cpu usage of vmware-vmx, but I can't find it anymore, and I think I actually manually fixed that problem myself.

    If anyone knows or can find the thread I'm talking about please link to it; I'm curious if that ever actually got fixed.

    I think I'm just going to re-make the VM when Windows 8.1 comes out and hope for the best...I really hope there is not an interoperability issue with these LaCie USB 3.0 Rugged keys.



  • 8.  RE: vmware-vmx 100% cpu usage...

    Posted Oct 11, 2013 10:34 AM

    Hi nkustreba,

    I have tired with USB key with format ExFat, but still could not reproduce the issue you mentioned.

    BTW, my OS version is 10.8.5 (12F45), well as I know, Apple release 10.8.5 recently.

    I suggest you upgrade your OS to 12F45, hope it will resolve your issue.



  • 9.  RE: vmware-vmx 100% cpu usage...

    Posted Nov 01, 2013 06:04 PM

    I found the problem.  It was the god damned windows search that auto installed itself from windows update.  After I uninstalled that everything is fine.  It appears for whatever reason, even though these LaCie keys are fast, they don't like it when they have 10000 commands thrown at them at once with the windows search service.  Oh well.  Probably whatever cheap NAND controller they're using can't handle all the requests. 



  • 10.  RE: vmware-vmx 100% cpu usage...

    Posted Nov 04, 2013 11:46 PM

    I have also been having high CPU usage and my system crawls after closing VMWare Fusion. It suspends the OS and quits but then the vmware-vmx stops responding and I have to force-quit it which then frees up my system (and restarts the process). Happens every time I quit Fusion on Mavericks