Fusion

 View Only
Expand all | Collapse all

VMware Fusion 13 -- Guest Tools Not Working (Ventura)

  • 1.  VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 02:22 AM

    Hello. I have been a VMware Fusion user for years but am about to give up on it. I've installed VMware Fusion 13 and NONE of the guest tools work for my Debian or Ubuntu VMs. No graphics--nothing. The VM looks like its an alien from 1993 VM technology. What happened?

    Here's my details:

    • MacOS Ventura 13.1
    • M1 Max (Macbook Pro 16)
    • Fusion 13.0.0
    • Debian 11, Debian 12, Ubuntu 22.04

    Things I've tried:

    • Reinstalling Debian/Ubuntu from LiveCD
    • Reinstalling VMWare Fusion
    • Uninstalling VMWare Fusion and deleting remnant files
    • Installing guest tools
    • Installing open-vm-tools(-desktop)

    What happens:

    When I install a VM, I am given no opportunity to install VMware guest tools. It says they are not available for this host. The screen resolution, if it changes, resizes the window. There is no copy/paste. There is no video acceleration or screen resizing. There are no shared drives. I can't actually complete a GUI installation of Debian because it tries to launch X using the vmware driver, which is not present.

     

     



  • 2.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Broadcom Employee
    Posted Jan 06, 2023 09:03 AM

    First, your post needs moving to the area for Fusion, so I have reported it to the volunteer moderators.

    Regarding you using Fusion 13 on an M1 Mac, this unofficial document may offer some tips: https://communities.vmware.com/t5/VMware-Fusion-Documents/The-Unofficial-Fusion-13-for-Apple-Silicon-Companion/ta-p/2939907

     



  • 3.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 03:46 PM

    Don't give up. All of these are fixable. This is a case where the Unofficial Fusion 13 for Apple Silicon Companion document found in the VMware Fusion Documents section of this forum is your friend and should help you get up and running quickly.

    Resolutions to all of these issues are discussed in the Companion.

    Debian 11.4 and later install out of the box (including using the GUI installer).

    Debian 11 contains a 5.10 kernel that doesn't have the vmwgfx VMware SVGA driver that allows console resizing. VMware donated the driver to the Linux source tree and is available as a standard part of 5.14 kernels and later. That's the only way to get the driver; it doesn't come with any "tools" installation. For Debian 11, you can install an updated kernel from the "bullseye-backports" repository that will allow screen resizing.

    open-vm-tools are known to be available for Debian 11 through the 'bullseye-backports' repo. I'm not sure if they are available in the main repo. You'll need these along with the updated backport kernel in order to resize the screen on Debian 11. Again, this is discussed in the Companion.

    Debian "testing" (which is currently the development version of what will become "bookworm" or Debian 12) boots and installs out of the box, and does contain the required driver. It also contains open-vm-tools and open-vm-tools-desktop packages in its repo.

    Ubuntu 22.04 and 22.04.1 do not boot from their distribution's released installers. These installers have kernels that contain bugs that prevented them from running on Fusion 13. Ubuntu has released updated kernels in updates to 22.04 that fix these issues, but the installers haven't been updated with that kernel. You can get the distro to install by starting with an installer from daily builds of Ubuntu 22.04. This is discussed in the Companion document (with links to where you can get the daily builds required).

    open-vm-tools are available for all of these distros from their respective repositories.

    Note that there is an issue in open-vm-tools (across both Intel and ARM Linux distros) where shared folders do not mount at boot. The resolution to this is also discussed in the Companion document.

    As you've found, there are no VMware Tools packages for Linux on ARM. The only tools available are open-vm-tools.

     

     



  • 4.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 04:09 PM

    I forgot to add that once you have Ubuntu 22.04 installed using the daily build installer, open-vm-tools cane installed from the Ubuntu repos.  Both screen resizing and shared folders will then work.



  • 5.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 04:45 PM

    Thank you for the detailed response.

    I decided to follow your advice for my Debian Testing (bookworm) VM, since it already has the open-vm-tools.

    Here is what I observe:

    • When I log in the screen resolution changes, and the size of the VMware window changes. This is not what used to happen. Is this normal? (I am in XFCE and KDE Plasma)
    • When I resize the window, I get black bars on the top or on the size that persist. Text actually gets bigger or smaller based on the size of the window (before, resolution would adjust).
    • I created the /mnt/hgfs folder.
      • The "toggle" of shared folders does work, as a workaround.
      • The /etc/fstab solution listed in the companion cause a boot hang on "A start job is waiting for Wait for Network to be Configured ( xx sec / no limit )
      • When in the above situation, toggling shared folders released the boot hang.

    So I think my issues are partially resolved, but I'd like to know if what I am seeing is what others are seeing.



  • 6.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 05:13 PM

    I run GNOME on Debian, so I haven't see the black bars on resize. I do run Plasma on OpenSUSE Tumbleweed and don't see that issue.

    If I've changed the resolution of the screen my GUI session, the resized screen does persist between logins on GNOME. I've seen that happen on other distros where I run KDE Plasma as well. 

    I'm not seeing the addition of the fstab entry cause a boot hang on my Debian Testing VM. If Sharing is disabled, there is an error thrown about failing to mount /mnt/hgfs, but the boot continues without issue. 

    I'll give this a whirl with the Testing distribution and install KDE Plasma and see if I get something different.

     



  • 7.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 05:32 PM

    Thanks. Just trying to confirm there isn't a problem on my end with my VMware installation. 



  • 8.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 06:06 PM

    Ok, I fired up the Debian VM with KDE instead of GNOME.

    I do see that when running a Plasma or default X11 session, dragging the window to resize it does not force a resolution resize in the VM. (black bands can occur). This doesn't happen with GNOME. Resizing the resolution from within the VM works. I'm seeing this on OpenSUSE Tumbleweed as well when running the default KDE Plasma session and sddm display manager. It's a known issue that the xfce window manager does not implement resolution change when resizing the window by dragging it (we found that out when look at Kali Linux). It also appears that Plasma has the same behavior. 

    Plasma does indeed remember what the display resolution was between login sessions. It's most evident when you reboot the VM, and the resolution gets set back to the defaults for the first time the login widget runs. Once you log in, the session resets the screen resolution to what it was on the your last login. Log out, and the sddm display manager resets the screen resolution back to its defaults.

    I'm not seeing the hang on boot when adding the /etc/fstab entry to auto-mount shared folders. One possible thing to make sure of is that the mount options specified on the /etc/fstab entry are exactly as noted in the Companion document. It must include the "_netdev" option. And yes, that is an underscore as part of the option. It's not a typo or whitespace.



  • 9.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 07:56 PM

    The line I have in my fstab is:

    Oh i could copy/paste but its not working still

    vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other,_netdev 0 0

    However, the systemd instructions worked quite well. I also had to chmod the mounted directories to get permissions to be right.

    Thank you for the help. I'm almost viable here. I mean its not nearly as good as Parallels is right now, but I can at least work pretty efficiently.



  • 10.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 06, 2023 10:20 PM

    I'm finding some strangeness with copy/paste with KDE Plasma on Debian. Copy/paste works fine on openSuSE Tumbleweed that runs KDE Plasma by default. I also find that copy/paste works fine on Debian Testing under GNOME.

    I suspecting something funky about how open-vm-tools have been integrated into Debian. They're not doing something that Tumbleweed does. In a working environment, there are 2 vmtoolsd processes running - one as root and the other as the logged in user. I'm finding that the latter process isn't running on Debian when you are running Plasma. This is in sharp contrast to Tumbleweed where the process is running. and things work. 

    I'm going to poke around some more and see if I can figure out what's up...



  • 11.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 07, 2023 05:58 AM

    I will spin up a Tumbleweed and confirm I am seeing what you are seeing.



  • 12.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 07, 2023 06:22 AM

    srysly_0-1673071875075.pngsrysly_1-1673071892353.pngsrysly_2-1673071922702.png

    This is my experience trying Tumbleweed on VMWare Fusion --- I highlight it just to note that I still suspect something might be wrong with the install.  That said---Ive done a fresh install of VMware Fusion as part of the troubleshooting process.... I booted from the aarch64 ISO on the OpenSUSE website.



  • 13.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 07, 2023 02:57 PM

    What you’re seeing is not a Fusion problem. There is a problem with the latest Tumbleweed aarch64 snapshots. This issue is also seen on UTM and Parallels as well a on any ARM physical hardware. It seems to have started with the 20221219 snapshot and is due to a bug in one of the gcc libraries. It has been reported to the OpenSUSE and gcc developers  

    Until the upstream maintainers fix this, a workaround is available: 

    • boot the install ISO and select “Installation” from the GRUB boot menu but don’t hit return. Type ‘e’ to edit the boot commands. 
    • Add the following to the kernel arguments:
    • arm64.nopauth
    • The kernel argument line should now read
    • linux /boot/aarch64/linux splash=silent arm64.nopauth
    • Type ctrl-x to boot. 

    Tumbleweed should now install normally. This kernel argument will persist into the installed VM. Don’t remove it until the issue is fixed as it impact upgrades as well as initial installs. 



  • 14.  RE: VMware Fusion 13 -- Guest Tools Not Working (Ventura)

    Posted Jan 07, 2023 03:08 PM

    I’ve found the KDE implementation on Debian Testing to be flaky. KDE doesn’t seem to want to start the vmtools user background process needed to support copy/paste right after the user logs in. Another background procedure kded5 also does not start. 

    What’s really strange is that this happens the first time I log in after boot. If I log out and log in again, it seems that copy/paste will now work. That points to me as something in the Debian distro that’s not quite right. 

    Copy/paste works fine on Tumbleweed with KDE, and  copy/paste works on Debian when using GNOME.  Shared folders work on Tumbleweed too (still need the entry in /etc/fstab or the systemd changes to get them mounted at boot time, though).