Fusion

 View Only
  • 1.  Problem with USB devices

    Posted Nov 16, 2014 12:06 AM

    Hey all,

    I am running VMWare Fusion 7.0.1, Mac OS X 10.10 latest updates and have a big problem with getting my virtual machines to work with SOME USB devices.

    As for virtual machines, I have tried both Windows 8.1 x64 and Windows 7 Professional x64, without much luck.

    With an external HDD formatted as Mac OS X Journaled, I get the message that it's detected properly, device manager shows it as an external HDD just fine however it doesn't appear as an external drive, whereas on my Bootcamp partition it did. With a USB stick formatted as FAT, everything works just fine and I can see it in 'My Computer', put files on it, etc. You might think it's the formatting of the external HDD to blame but the problems don't stop here.

    I have an FTDI based device that sets up a serial COM port. Sometimes this COM port (COM4) appears set up in device manager, but no software can actually interact with it. This means that the software can detect it, but it can't actually use the device in any way. Other times it just appears with a yellow exclamation mark inside of devices & printers, and when I try to install its drivers I get that the installation completed but the driver is still missing...

    What I've tried:

    1. removing the USB controller and adding it again

    2. reinstalling VMWare tools

    3. reinstalling VMWare fusion

    4. trying this all on a Windows 7 v. machine

    I am out of ideas of what to do. I'm tempted to think it might be due to Yosemite, but I'm clueless otherwise. Please advise!

    EDIT: My problem disappears in Parallels, so it's definitely VMWare related!



  • 2.  RE: Problem with USB devices

    Posted Nov 28, 2014 12:59 PM
      |   view attached

    I also experience problems with an USB device on Yosemite/Fusion 7/Windows 7. The communication to my device cannot be established.

    All worked fine with Mavericks/Fusion 4/Windows XP combination.


    The server process from the device starts ok and runs as long as the USB device is not connected, but after the connection the server immediately crashes.

    I have tried 64-bit and also with 32-bit versions of Windows 7. Also reinstalled the driver for the USB device in question. The problem remained.


    But, the weird thing is that out of blue a pop-up window appeared once on the screen (screenshot attached).

    After that I could use my USB device for about half a day and then it stopped again.

    Does anyone have a solution for this? Thanks.