Fusion

 View Only
  • 1.  Fusion PXEBoot Not Working

    Posted Apr 26, 2023 09:28 PM
      |   view attached

    I am using Fusion 13. 

    I am trying to get familiar with VMware Imaging Appliance with VMware Cloud Builder. I have created a blank server with the setting configurations of HD, NIC and network etc. I have located the correct MAC address for the system and trying to get the VM to pickup. I am inside VIA and [ /home/admin ]# tail -f /var/log/vmware/vcf/evorack-imaging/via.log. I am showing that the MAC is found and DORA finished but the IP Address never connects with the system. I am also running a ping against the the IP which never is successful. Below is what VIA is showing.

    To me looks like this line is showing there communication:

    [pool-5-thread-5] INFO : com.vmware.vrack.via.microservice.manager.ImagingServiceManager - Sending re-imaging request for device type ESXI_SERVER, ip 10.12.11.201 to the imaging service http://10.12.11.240:8081 to proceed further.

    --

    I have tried changing inside the VMX file ethernet0.virtualDev = "vmxnet3" to ethernet0.virtualDev = "e1000e" and back with no luck. Can Fusion do PXEBoot? Is there another setting I am missing? 

     

     

    METACORTEX_0-1682544263761.png

     

    Attachment(s)

    txt
    via_tailOutPut.txt   35 KB 1 version


  • 2.  RE: Fusion PXEBoot Not Working

    Posted Apr 26, 2023 09:30 PM

    Are you on an intel or M1 mac?  If the latter, it can't run x86/64 vm's so that may be the issue.



  • 3.  RE: Fusion PXEBoot Not Working

    Posted Apr 26, 2023 09:50 PM

    Intel MacBook Pro 16'. The image is 64. I was able to install the version of esxi with no problem. Seem its the PXE Boot networking function not working right. 

    I also tried changing the BIOS from UEFI to Legacy BIOS with no luck. 



  • 4.  RE: Fusion PXEBoot Not Working

    Posted May 02, 2023 02:42 AM

    What's the virtual networking type that your VMs are configured with? VMs? Bridged, NAT, or Host-only?

    Is it possible that you have conflicting DHCP servers - the one provided by default by Fusion, and a DHCP server that's provided by the Imaging Appliance? If so, I would think that you need to disable Fusion's DHCP on that network segment and let your appliance provide DHCP services (which include TFTP services) for the virtual network segment you're using for your Imaging Appliance and the ESXI VMs.



  • 5.  RE: Fusion PXEBoot Not Working

    Posted May 02, 2023 01:30 PM

    I am currently using NAT. I have disconnected everything eliminate a networking issue with no luck. 

    I have set the server to Legacy BIOS after documentation specified this with no luck. Interesting since VCF is requiring UEFI in the VVD.

    I have disabled DHCP for the network in the image below. If there is another place to disable I am not aware of it. I do have Server 2019 doing DNS and DHCP. DHCP was turned off and tested with another host on the network not receiving and IP then enabling and the host received one after renew. 

    What is confusing me is that the tail -f of the log file is show the MAC address and saying it is assigning the IPADDR, but the system is not showing that. I have regenerated multiple MAC ADDR but same result.  

    I had tried standing up an ESXi host and configured a guest to be the install point but it still was not being seen. That might have been my configuration issue since I was just trying to test. 

     

    METACORTEX_0-1683030681961.png

    METACORTEX_1-1683032825960.png

     

    For Giggles, I installed esxi just to see if it would receive and IPADDR without VIA on. To investigate further your DHCP Idea. But There is no IPADDR. 

    I then started VIA to see if it would provide and IPADDR to the server. When I reset the ESXi host network, the associated DHCP reservation IPADD was provided. 

    METACORTEX_2-1683033421844.png

    Recap:
    - Created new VM shell, Legacy BIOS and captured MACADDR
    - Input info into VIA for DHCP
    - Started VIA Imaging 
    - Boot VM with Networking
    - Rebooted and tried again, ( 4 ) times
    - Stopped VIA Imaging
    - Installed ESXi on VM shell
    - Once up showed no IPADDR was found,
    - Started VIA Imaging ( DHPC TEST )
    - Login and Restarted Management Network
    - Verified that the ESXi Host received DHCP Reserved IPADDR
    - Shut ESXi Host down and changed the boot to network
    - Started ESXi Host
    - Host does not receive IPADDR from DHCP Server
    - Boot to ESXi
    - Restart Management Network to verify IPADDR received
    - IPADDR received at ESXi Host level.

    METACORTEX_3-1683034052476.png

     

    In conclusion it would appear that the VMs are not able to PXE Boot. The IPADDR is received at the Host level but not at the BIOS / Network PXE level. 



  • 6.  RE: Fusion PXEBoot Not Working

    Posted May 02, 2023 09:08 PM

    For what it’s worth, I’ve been experimenting with setting up a Debian arm64 VM as a network boot and install install server and configuring another VM to PXE boot from it.

    The PXE boots and access to the tftp server have gone through but I’m having a few issues with the right files to put in the right places in the tftp directory. I’m beginning to suspect you’re having a configuration issue rather than a failure of fusion to PXE boot. I’m not claiming success though until I get that other VM booted. 



  • 7.  RE: Fusion PXEBoot Not Working

    Posted May 03, 2023 01:43 PM

    Spent quite some time investigating VMware documents on VMware Imaging Appliance configurations and everything is stating to configure as below. 

    vim /opt/vmware/evorack-imaging/config/via.properties 

    # SECTION I : No Change System configs unless interface is different: 

    via.network.interface=eth0
    via.web.url=10.12.11.240
    via.network.ifaceaddr=10.12.11.240
    via.dhcp.esxi.tftpServer=10.12.11.240
    via.config.remote.pxe=false


    # SECTION II

    via.dhcp.netmask=255.255.255.0
    via.dhcp.subnet=10.12.11.0
    via.dhcp.routers=10.12.11.254
    via.esxi.firewall.allowed.network=10.12.11.0/24

     

    After hours of trying different things, I decided to change the MAC Address to see if for some reason it is being blocked. It's working at OS level but maybe something with PXE. 

    I tried to change it in the Network Adapter settings, but it would not keep the MAC address after starting the VM. I then had to locate the [VM-NAME].vmx file and edit in a text editor. This file is located in the [VM-NAME].vmwarevm. Right-Click, Show Package Content to show the list of files.

    Change the line from : ( ethernet0.address = "00:50:56:38:95:F8" ) to ( ethernet0.address = "00:52:56:38:95:F8" ), save. Changing the second block from 50 to 52

    This alone did not work. After changing the setting and saving the change in the .vmx file, I also had to change it in the Network Adapter settings as well for it to be accepted. 

    After those changes I was able to see PXE boot work. Now I will work on figuring out how to edit the install files. 

    image.png

     

     

     



  • 8.  RE: Fusion PXEBoot Not Working

    Posted May 03, 2023 02:55 PM

    Well I wish I could have found this page days ago. No. 3 would have been great to know. It would appear there is a MAC address / DHCP restriction with VM guests. 

    via-vmware-imaging-appliance

    At the bottom of the page under unsupported. ( LAB USAGE )

    1. Custom kickstart-url to allow local boot-device (and more)
    2. Change existing kickstart-file to allow local boot-device (and more)
    3. Disable the dhcp-restriction to allow imaging nested ESXi-VM’s


  • 9.  RE: Fusion PXEBoot Not Working

    Posted May 03, 2023 06:06 PM

    That's very interesting. So they're specifically blocking MAC addresses that they know come from VMware virtual NICs as they're assuming those NICs have a specific vendor prefix. That would explain why changing the second byte in the MAC address from 50 to 52 worked for you - the NIC no longer gets identified as a VMware NIC.