Fusion

 View Only
Expand all | Collapse all

Windows 7 problem with external USB drives

  • 1.  Windows 7 problem with external USB drives

    Posted Sep 04, 2012 04:41 AM

    I'm trying to get my Windows 7 Home Premium installation in VMWare to see external USB drives. I've tested with a LaCie Rugged Mini and with a Western Digital My Passport, both USB 3.0, both compatible with USB 2.0. When I plug one in, I get the message from Fusion:

    "The device "Western Digital My Passport 0740" was unable to connect to its ideal host controller.

    An attempt will be made to connect this device to the best available host controlle. This may result in an undefined behavior for this device.

    Then after I ok that message, Windows reports:

    USB Device not recognized.

    One of the USB devices connected to this computer has malfunctioned, and Windows does not recognize it. For assistance in solving this problem, click here.

    After clicking that, the drive is shown as Unknown device, and the advice is to disconnect an reconnect it (which always gives the same result. Searching for drivers within Windows does not help.

    Uninstalling and reinstalling VMWare Tools does not help.

    Switching between the two drives, two USB cables, and two USB ports does not help.

    Removing and readding the USB card to the machine does not help.

    Setting the USB card to USB 3.0 makes the virtual machine refuse to boot at all.

    Hardware is a Retina display MacBook Pro, running 10.7.4, drives are set to show up in Windows, not Mac. Any ideas? I'm at a loss. Other USB devices seem to work fine, just no luck with hard drives.



  • 2.  RE: Windows 7 problem with external USB drives

    Posted Sep 05, 2012 03:29 AM

    As an update, I'm running Fusion 5.01, and the same thing happens with my Windows XP Home installation. Anyone else having this problem?



  • 3.  RE: Windows 7 problem with external USB drives

    Posted Sep 05, 2012 12:36 PM

    Yes I have the same problem. On a physical notebook (only USB 2.0) my USB 3 devices are working fine, also in vmware Workstation 8 and Windows 7

    --> devices are  therefore ok.

    Until now I did not test USB 2 Devices and Fusion. What I did not understand is, why the USB 3 devices do not work as USB 2.0 in Fusion.

    Windows XP on VMware 8 works also with the USB 3 devices

    I think the whole issue has something to do with the Fusion usb drivers which are (I think) in the OS Profiles.

    I saw a workaround suggested from vmware:

    - use the sharing option to connect to your usb 3 devices

    - on my Retina MBP and Fusion this works well



  • 4.  RE: Windows 7 problem with external USB drives

    Posted Sep 05, 2012 02:39 PM

    Sharing works alright for files, but I want to use one of these drives for Windows backup. The Home Premium that I have doesn't support backup to network shares, so I need to be able to connect the drive directly.



  • 5.  RE: Windows 7 problem with external USB drives

    Broadcom Employee
    Posted Jul 25, 2013 02:56 PM

    I'm on Fusion 5.0.3 and have the same problem with my 1 TB Passport 0740.  What's strange is that I had it working fine with Fusion and a Windows 8 instance on a different MBP Retina, but on a different MBP Retina with a Windows 7 VM, I keep getting the same errors that you are.



  • 6.  RE: Windows 7 problem with external USB drives

    Posted Jul 25, 2013 05:05 PM

    You must be using a usb 3 device which will work fine on Windows 8 VM. In Windows 7 there are no drivers for the usb 3 controller and hence it may not work . To workaround this you may make use of external usb 2 hub to connect your device to windows 7 vm.



  • 7.  RE: Windows 7 problem with external USB drives

    Posted Oct 25, 2013 03:01 PM

    I had precisely the same problem also with a MacBook Pro running the latest version of VMWare Fusion that wouldn't talk to a WD My Passport drive, and the solution proposed by avanish321 (to plug the drive in through an external USB hub) worked perfectly, the first time.  I'm grateful.



  • 8.  RE: Windows 7 problem with external USB drives

    Posted Nov 24, 2013 01:11 AM

    Windows 7 does not support USB 3 drives. (Windows 8 does support USB 3.0) There is no workaround.

    (Installing HFS4Win does not resolve issue).

    You need USB 2.0 for all drives using Windows 7 on VM Fusion 5

    As per avanish321 you may try an external USB 2 hub but not sure if USB 3 will work through a USB 2 hub (working on it but haven't tried)

    Also, remember to use NTFS format for drive (Windows 7) as FAT 32 won't store files over 4 GB.



  • 9.  RE: Windows 7 problem with external USB drives

    Posted Nov 25, 2013 10:20 PM

    It works just fine through a USB 2 hub.



  • 10.  RE: Windows 7 problem with external USB drives

    Posted Feb 12, 2014 12:08 AM

    My computer would not recognize my external Passport drive at all.  I tried everything.  I sought out technical help and all other resources, tried drivers, et. also.  Then my last choice was to use the USB cable from my other Passport drive, and immediately my computer recognized the Passport drive that wouldn't work before.  It was just the USB cable that was preventing my computer from recognizing my Passport drive.  It has been working great ever since I switched the USB cable.  After all the headaches, I finally solved the issue with a very simple switch.  I hope  the rest of you will try a different USB cable also, good luck!



  • 11.  RE: Windows 7 problem with external USB drives

    Posted Jul 27, 2014 02:30 AM

    I have a latest Macbook Pro Retina and VMware Fusion. I having the same problem where the Windows 7 VM is not able to access the external WD with NTFS format and USB 3.0.

    Sharing worked fine but I am unable write files. I verified that VMware Fusion Settings > Sharing > Shared Folders had Read & Write permissions.

    Any recommendations how to make the drive writeable thought the Windows 7 VM?

    I understand the Host system is Macintosh and would have only read access for NTFS formatted drives.



  • 12.  RE: Windows 7 problem with external USB drives

    Posted Jul 28, 2014 09:21 PM

    Windows 7 doesn't support USB 3, so therefore, Fusion can't virtualize them.  Put a USB 2 hub between the drives and the computer if you want to mount directly in the VM as NTFS, or reformat as non-NTFS and mount to the host, and then share via shared folders.

    One other options:  Other folks here have had luck with 3rd party ntfs drivers for OSX, but they've been nothing but trouble for me - corrupt data, and crashed drives.