For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 65
Registered: ‎08-22-2008

HTTP Access to DS-4100B


     I seem to be having some problems viewing the GUI frontend of this EMC badged Brocade 32 port. It is currently at 6.4.1b. When I input the IP address of the switch into my browser IE8 running Java, The app seems to start the errors unable to open application. I was on a higher version of java, but after reading that if may be too new I uninstalled V6 update 26 as it did not work on this version either,

This is the error

at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$ Source)
at Source)"

I like to use the GUI as I'm rubbish at remembering the commands..

I know I need to use the cli commands at times, But How do i find out if the HTTP service is running ?



Posts: 0

Re: HTTP Access to DS-4100B

Hi -

you should try another browser (firefox, chrome) to see if you have the same issue with java plugin.

To answer your question, log in as root to see if httpd runs :

myswitch:root> ps -edf |grep http
root      1681     1  0  2010 ?        00:00:01 /usr/apache/bin/httpd.0 -f /fabos/webtools/bin/httpd.conf.0
nobody    1684  1681  0  2010 ?        00:00:00 /usr/apache/bin/fcgi-pm -f /fabos/webtools/bin/httpd.conf.0
nobody   12247  1681  0 09:47 ?        00:00:03 /usr/apache/bin/httpd.0 -f /fabos/webtools/bin/httpd.conf.0
nobody   15394  1681  0 15:56 ?        00:00:00 /usr/apache/bin/httpd.0 -f /fabos/webtools/bin/httpd.conf.0
nobody   15863  1681  0 16:56 ?        00:00:00 /usr/apache/bin/httpd.0 -f /fabos/webtools/bin/httpd.conf.0
root     16183 16101  1 17:22 pts/0    00:00:00 grep http

No doubt it's running and you have a java issue on client side.

Hope this helps

Kind regards,



Posts: 0

Re: HTTP Access to DS-4100B

Hello Phil,

did you have checked the recommendations from Brocade for IE settings written in the Webtools Admin Guide?

In the past if similar issues came up I have deleted the Temp Internet files and the Java cache as well. In 10 of 10 cases it was the browers and a local client issue. It was never a switch issue.

Did you have any AD policies on your client which disallow Java script running?

Was your Internet browser on your PC ever been able to load webtools? If yes what had changed since then?

I hope this helps,


Posts: 0

Re: HTTP Access to DS-4100B

I ran across this one a few months back. The issue was not the version of Java or the browser used. We had to go into the control panel of the window desktop then into JAVA and delete all history and temp files from the JAVA dialog box.

Another instance of this cropped up where we had to do the above and then remove and reinstall JAVA to get that desktop to connect.

IE and FireFox both were getting the same errors you are reporting.

Hope this helps.

Posts: 65
Registered: ‎08-22-2008

Re: HTTP Access to DS-4100B

Thankyou all for taking the time to respond, but after following the suggestions I'm still unable to launch the wetools on my laptop Win7 x64 IE 8 And java V6 update 26. This is down to my laptop, as I can connect to the webtools using a Win2k server. I have uninstalled Java cleared the IE temp files etc - reinstalled but still no joy,

I'm going to see if it will work using virtual PC.

Thanks for all your comments

Occasional Visitor
Posts: 1
Registered: ‎11-01-2016

Re: HTTP Access to DS-4100B

I am experiencing a similar issue for a user at my company. I deleted temporary internet files and I have reimaged his machine and it was good for about a week now he is unable to access any of the switches. 

Community Manager
Posts: 297
Registered: ‎03-03-2014

Re: HTTP Access to DS-4100B



Thank you for your post on the Community.   Our technical team looked into your question, due to the 4100 being EOS/EOL (End of Life/End of Support), we are unable to assist with our question.


If you would like a referral to sales I would  be glad to assist.


Thank you
Jason McClellan
Community Manager





Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.