For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 0

Fos fpga_update ERROR

Hi all,


I've upgraded 4 blade switches (IBM 44X1921, Brocade 5470) from Fos 6.2.0c to 6.3.1 to 6.4.2b.

Only on two switches, i can't update the fpga from 96 to 97. The two others have been updated successfully.

I've upgraded one from 6.4.2b to 6.4.2b4, and the fpg_update failed with the same error, as follows:



NOM-SWFCBCH-2:admin> fpga_update
The current FPGA version is 96.
FPGA version 97 is available.
You should update the FPGA to the new version.
Warning: FPGA update will disrupt traffic flowing through this switch.
It will also cause the switch to restart.
Do you want to update the FPGA to version 97? [N] Y
Please avoid powering off the switch during programming.
When programming completes, the switch will reset itself.

JTAG programming file /fabos/share/63-1000427.xsvf

.ERROR:  TDO mismatch
ERROR at or near XSVF command #8. See line #8 in the XSVF ASCII file.
Programmed /fabos/share/63-1000427.xsvf file successfully


I don't find any workaround about this error.

However, all switches works fine.


Do anyone experienced the same error ?





Posts: 0

Re: Fos fpga_update ERROR

I've never seen such a message out in the wild nor on the forums here.

To be honest I didn't know of such a command nor can i find it in the cmd ref guides.

Only thing I can tell you is to open a ticket with IBM support (as you bought the IBM badged switch) and let them explain it.


Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.