For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 41
Registered: ‎05-24-2010

Brocade Fibre HBA MSCS Luns "No disk suitable for cluster disks were found"

Windows 2008R2

IBM Server

Fresh installation with firmware and driver updated

Trying to build MSCS and once I added the failover service I tried to add the disk volumes.  I did my usual of mapping the six volumes to the hosts and making sure they can individually see the volumes and write data to them (map to one host, format and create data, then shut that server down and then map to second cluster node and import and write data).

I then go to add the disk object as a resource for MSCS

No disk suitable for cluster disks were found. For diagnostic information about disks available to the cluster, use the Validate a Configuration Wizard to run Storage tests.

I then found this web support matrix by IBM

Windows 2008 Server (Using MPIO)  -->

Host Bus Adapter
HBA Firmware
HBA Driver
SAN Boot
32 & 64 bit Editions

It notes clustering as no.


1) Is this still the case that brocade's Fibre Adapters support SAN boot but not MSCS?

2) Their is no note related to support for Microsoft HyperV for the Brocade cards.  Some vendors note that they support SAN boot, or SAN boot with MSCS but NOT HV.  From what I understand, this is all related to the ability for Windows 2008R2 to support and work with SCSI 3 lock reservations. Is their a good article on this, and a sequence one can test related to a locking issue.

3) If the Broacde Fibre cards have these "holes of support" is this just related to IBM's SDD MPIO driver. If so, can I revert back to the Microsoft MPIO native drive and eliminate this issue?


Posts: 41
Registered: ‎05-24-2010

Re: Brocade Fibre HBA MSCS Luns "No disk suitable for cluster disks were found"

Worked with Brocade Master today on issue.

Boot code on one of the controllers was backreved. We booted the live_cd_v3-0-0-0.iso   live CD and firmwared flashed this and once this was done... we reconstructed the LUNs back to the host and it enabled the MSCS shared disk to work.

Flash command:

Flash Command
# bcu boot --update 1 brocade_adapter_boot_fw_v3-0-0-0

That was the fix.


Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.