For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 0

Brocade 4900 / IBM 2005-B64 damaged firmware



i made a huge mistake! I tried to update my IBM 2005-B64 SAN-Switch to Firmware 6.4.3f. But since i have no idea how long this process is taking i cutted power while the update was running.


I am now stuck with the message "Cannot make/remove an entry for the specified session" , if i try to login via serial with all login credentials. (admin - password, root - fibranne) I also tried a wrong password, and get the "correct" answer - Login failure attempt via SERIAL.

If i try to access the switch via IP i get "Status: 503 Chassis i snot ready for management now. Please try after some time"


After advice from a more experienced admin, i should open the chassis, and take out the CF-Card to restore the firmware.

Now i am wondering, the CF-Card has a size of 512MB, the Firmware has almost 900MB.

I tried to set the switch back to boot from the primary Image by changing boot order, but this doesn´t help...


Is there any possibility to get the machine up and running again?






Posts: 0

Re: Brocade 4900 / IBM 2005-B64 damaged firmware



i have to answer the question myself...


First of all i have to thank "danabrams" for his hint.


No.  This is obviously where I've gone wrong.


I have, however, fixed the switch by following the Password Reset Procedure:


I really dodged a bullet there.




Press escape within 4 seconds to enter boot interface.


1) Start system.
2) Recover password.
3) Enter command shell.


Option? 3
Password: <hidden>
> printenv
LoadIdentifiers=Fabric Operating System;Fabric Operating System
> boot ATA()0x19bf58 -s
Booting "Manually selected OS" image.




sh-2.04# mount -o remount,rw,noatime /

EXT3 FS on hda2, internal journal
sh-2.04## mount /dev/hda1 /mnt
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda1, internal journal
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
sh-2.04# /sbin/passwddefault
passwdCfg: fabosInit failed with -1
All account passwords have been successfully set to factory default.
sh-2.04# reboot -f
Restarting system.

This was the first i have to do, to get control of the switch again. Maybe the useraccounts were damaged by hitting the powerbutton while the update was running...


The second Problem was: RTFM!

In the Troubleshooting-Guide was assumed, that you should issue the diagDisablePost - Command before you perform an update.


I didn´t do that, and therefore i couldn´t issue firmwaredownload again.


After issuing the command i was doing the firmwaredownload again and voilá  - switch is running again..


But.. is it running again....? Nope... if i issue diagEnablePost , and performing a reboot the Switch is reported as faulty....


So, maybe the problem occurred because i didn´t run the update in the right order? Maybe the machine was running an older version of FabOS and normally i had to use one or two steps between the updates?


How can i find out, if i need a downgrade to Update the switch to v6.4.3f?






External Moderator
Posts: 5,594
Registered: ‎02-23-2004

Re: Brocade 4900 / IBM 2005-B64 damaged firmware



--->>>But since i have no idea how long this process is taking i cutted power while the update was running.....


indeed, you made a big mistake by interrupt and power done the switch during FW upgrade, and most probable the CF is corrupted.


If so, there is in most case no way to recovery the OS, with other words the switch is dead.


before we discuss here for long time, tell me from which exact FOS release you start the Upgrade to 6.4.3


About you question FOS package Size, in feew words,.... the FOS package is a Image for several Switch Model and have nothing to do with the CF Size of 256 MB, this is the correct package.


Posts: 0

Re: Brocade 4900 / IBM 2005-B64 damaged firmware



this must be the case.. the CF-Card can be corrupted. BUT: i get a operational Switch if i stop the DIAGPOST before i start the Switch.


I recently checked my Logfiles (Thanks to SecureCRT that i´m using - all output will saved to a file) the Version before "my fault" was v5.3.0b .


After the first "update" and after resetting the userdata to login again, the switch shows v6.4.3f .


I tried firmwarecleaninstall (and restored the licenses after that) but it´s the same now. If i let DIAGPOST Enabled i get a switch with "faulty" status and i can´t login to the webinterface. If i disable it, the switch runs normally....


But i would prefer to get the switch operating with POST Enabled....


Many thanks for your help in this project!!



aka meisterdausi

Posts: 0

Re: Brocade 4900 / IBM 2005-B64 damaged firmware



after a Night with rolling all updates (nearly) back to v5.3.0b (i had only v5.3.1a available) it turns out that only v6.0.0 is running without fault.


I ran any update step by step from v5.3.1a to 6.4.3f (approx 8 Updates), but only with v6.0.0 the POST runs perfect...


Does anyone have advice on this?


Kind Regards,



Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.