For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 0

6.4.0 breaks with AP7420?

My fabric:

4900 <--fc--> ap7420 <--ip--> ap7420 <--fc--> dcx4s

ap7420 is running v7.4.1f

if I upgrade the 4900 to version 6.4.0b I lose the ISL with the ap7420. It's only saying: port 32, incompatible operating mode

Downgrading the 4900 to v 6.3.1c, doing a portenable, brings back the ISL.

The dcx4s is also running v6.4.0b and is not having this problem.

Can it be any setting on the 4900?


Posts: 0

Re: 6.4.0 breaks with AP7420?

I doubt it on AP7420. You can compare the 4900->AP7420 configuration and DCX4s-> AP7420 configuration.

AP7420 is EOL, EOS & EOA

BTW 4900 is 4 Gbps and DCX4s is 8 Gbps , Suggestions to use 7500/7500E. These are also no longer orderable.

The bestway is to use brocade's latest 8 Gbps 7800, which has

  • Up to sixteen 8 Gb/sec Fibre Channel ports
  • Up to six 1 GbE ports

You can suggest the customer

External Moderator
Posts: 5,654
Registered: ‎02-23-2004

Re: 6.4.0 breaks with AP7420?


I coming back here, after some comment have be removed.

Please have be patience.

Thank you.

Posts: 0

Re: 6.4.0 breaks with AP7420?

thanks for your respons, I checked to port settings on the dcx4s and the 4900.

There were some differences;

QOS E_port is off by default on 4900 and on on the dcx4s.

now portcfgshow says ON on the 4900 and AE on the dcx4s, I guess this has to do with the hardware.

locked G_port was ON on the 4900, changing it to OFF did not chenge any thing.

Worth to mention I think: the ISL did not go down during the firmware upgrade. Only if the connection fails, it connect be reconnected!

About the suggestion of buying 7800, the WAN link is always 1GB, this is the bottleneck, not the 2GB fibre interfaces of the 7420.

What arguments should I give for this investment to my client? The routers are only used for this WAN connection.


Posts: 0

Re: 6.4.0 breaks with AP7420?

Thats very good that you have found the differences. Have you tried to do the modifications?

<locked G_port was ON on the 4900, changing it to OFF did not chenge any thing>

I did not get it exactly.

<the WAN link is always 1GB>

It does not make the difference whether u have 1 Gbps WAN link.

I have 7500E routers and the link is 620 mbps only. So u can suggest in terms of SAN. For FCIP , IP WAN will definitely come.

Posts: 0

Re: 6.4.0 breaks with AP7420?

Yes, I tried all the modifications, but with the same problem.

the port setting is now:

pmfcsw06:admin> portcfgshow 32
Area Number:              32
Speed Level:              AUTO(HW)
Fill Word:                0(Idle-Idle)
AL_PA Offset 13:          OFF
Trunk Port                ON
Long Distance             OFF
VC Link Init              OFF
Locked L_Port             OFF
Locked G_Port             OFF
Disabled E_Port           OFF
Locked E_Port             OFF
ISL R_RDY Mode            OFF
RSCN Suppressed           OFF
Persistent Disable        OFF
LOS TOV enable            OFF
NPIV capability           ON
QOS E_Port                ON
Port Auto Disable:        OFF
Mirror Port               OFF
F_Port Buffers            OFF
NPIV PP Limit:            255

pmfcsw06:admin> portshow 32
portIndex:  32
portName: ISL_pmfcrt02
portHealth: OFFLINE

Authentication: None
portDisableReason: Switch incompatible
portCFlags: 0x0
portFlags: 0x4021        PRESENT U_PORT DISABLED LED
portType:  10.0
POD Port: Port is licensed
portState: 2    Offline
Protocol: FC
portPhys:  6    In_Sync         portScn:   2    Offline
port generation number:    10
state transition count:    7

portId:    672000
portIfId:    43020000
portWwn:   20:20:00:05:1e:03:ea:3e
portWwn of device(s) connected:

Distance:  normal
portSpeed: N4Gbps

LE domain: 0
FC Fastwrite: OFF
Interrupts:        47         Link_failure: 1          Frjt:         0
Unknown:           0          Loss_of_sync: 3          Fbsy:         0
Lli:               47         Loss_of_sig:  5
Proc_rqrd:         291        Protocol_err: 0
Timed_out:         0          Invalid_word: 508816
Rx_flushed:        0          Invalid_crc:  0
Tx_unavail:        0          Delim_err:    0
Free_buffer:       0          Address_err:  0
Overrun:           0          Lr_in:        3
Suspended:         0          Lr_out:       33
Parity_err:        0          Ols_in:       1
2_parity_err:      0          Ols_out:      3
CMI_bus_err:       0

Super Contributor
Posts: 644
Registered: ‎03-01-2007

Re: 6.4.0 breaks with AP7420?


I'm using here the AP7420 connected to FOS 6.4 and work fine, and i have here no doubt!

e.g. see this Thread.

however i note from output the port is set as Negotiated, Please set to Fixed 2 GB.

Another Question, are you in Native or Interop-Mode ?

Posts: 0

Re: 6.4.0 breaks with AP7420?

Hi, thanks for responding.

I tried all the speed mode settings (auto-auto, fixed-fixed and fixed-auto) but no luck.

I am using native mode.

Did your link ever go down after the upgrade to 6.4.0? I didn't knew I had a problem until the power maintenance last week. The link doens't come up any more. If I downgrade to 6.3, I can bring up the link, upgrade to 6.4 and everythings is working. But I don't want a situation like this of course.


Super Contributor
Posts: 644
Registered: ‎03-01-2007

Re: 6.4.0 breaks with AP7420?

I'm on 6.4.0a at the moment, I'll update this week to b release, but I don't think this is a problem.

--->>>I didn't knew I had a problem until the power maintenance last week.

AP7420 is a excellent Plattforms, Rock Solid but very hard, and sometime very stubbornly.

Is probable that power maintenance or reboot caused such error when the config was not saved.

can you tray follow :

in AP7420,

1) Stop the port and the

2) disable a port set offline

3) remove the cable

4)swap the SFP.

5) reinsert the SFP now

6) start the port

7) plug a cable

8) enable the port set online

alternate use a viceversa procedure 7-8 to 8-7

also First enable the port then plug a cable.

let me know.

Posts: 0

Re: 6.4.0 breaks with AP7420?

I verified the config with a backup of the config file from before the reboot and they are the same.

I tried the procedure that you wrote me, but with 6.4.0b, the link will not be established.

I know that the AP7420 is a very robost platform, but it's not the first time that I have an incompatibility between this Rhapsody router and a Brocade switch. I try to open some calls, but the AP7420 is from HP and the 4900 is from SUN, so it will be a long way....

Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.