For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 0

4020 switch - does not recognize putty login for new user

I am stumped.  I created a new user on my Brocade 4020 blade switch (running 6.2.2d) so someone can try to help me with scripting.  I created this user as an admin and made it exactly like my user account.  I can log into webtools without an issue, though when I look at auditdump -s output, it doesn't really look like it thinks I logged in with the new user, but shows I logged out as the new user.  I then went into webtools and changed the password for the newuser while logged in as the newuser and at least now the audit shows me logged in as the newuser with webtools.

The issue that has me stumped is that when I try to connect with Putty as my newuser, I get to type in the user name and password, then the session goes away.  I look at the putty log, and all it shows is that I typed in my username and password and nothing else after that.  It does not show at all in the audit that I logged in as that newuser.  However, I have no problem logging in with my personal user with putty.  Same computer, same putty icon, every thing the same except the user.  And everything for the new user is the same as my personal user.

Does anyone have any thoughts on this?  I like to think it has to be some simple thing I'm missing, but it isn't being easy to figure out.



External Moderator
Posts: 5,654
Registered: ‎02-23-2004

Re: 4020 switch - does not recognize putty login for new user


i had the same experience / issue with 4020 and FOS 5.3.x, however i see you are on FOS 6.2.


have you created the new username as low characters ?

If yes, try again to create another test user with BIG characters, i.e.


Posts: 0

Re: 4020 switch - does not recognize putty login for new user

Thanks for the idea.  I just tried that this morning, but it didn't work.

I think I figured this out, though.  But it still doesn't make sense... This switch is a subordinate switch that has a password policy pushed to it from the primary.  Even though I did not lock down to say I can't change anything on that switch only, apparently it doesn't like it.  Once I created the user/pw on the primary switch and distributed the policy, I could use the new user with putty.

So, that solves my problem, but does not answer all my questions.  If anyone can explain why it is that

1 - webtools worked but putty did not for new user log in

2 - audit log did not have any entry (incorrect password would list something, correct would just kill putty window)

3 - entering a user on the subordinate switch after a policy push caused issues at all

I would be very happy!



Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.