For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 0

200E firmware upgrade question


I am tyring to upgrade the firmware on some 200E's but I am having an issue with the release.plist.  I have 4 200E's on firmware version 5.0.1a.  I just came into possession of them and need to get them up to date.  In the extracted zip file there are 18 or so directories SWBD10, SWBD12, etc.  All of them have a release.plist in them.  When I pick one it fails with the error "Firmwaredownload failed. (0x12) Cannot access package list (.plist) file."  Which is the correct release file for a 200E?

Thanks in advance for any help.

Super Contributor
Posts: 644
Registered: ‎03-01-2007

Re: 200E firmware upgrade question

unzip the FOS, and make sure the FTP is pointed in the folder which contain the new firmware, example


make sure the FTP is correct configured, and in same IP Rage as the Brocade switch.

Start firmwaredownload , the file name is as example: /v5.1.0/release.plist

Posts: 0

Re: 200E firmware upgrade question

Thanks for the input, but I have tried that.  I read all the posts I could find before I posted and I can't seem to get around this issue.

I have tried pushing the firmware updates with DCFM.  That does not work.  I get the same error message.

I have tried connecting directly to the DCFM ftp server.  That does not work.

I have tried another standalone ftp server.  That does not work.

I have tried shortening the path to the files on the ftp server.  That does not work.

In all instances of this failure I can connect from another computer (both UNIX and windows) and get files from the ftp server.

From what I understand the release.plist is created by the firmwareDownload process on the Silkworm.  There is no physical file called the release.plist at the root of any version of the firmware zip.

This is the error text.


This command will cause the switch to reset and will
require that existing telnet, secure telnet or SSH
sessions be restarted.

Do you want to continue : y
Server Name or IP Address:
User Name: admin
File Name: //v5.1.1b/release.plist
Firmwaredownload has started.
Firmwaredownload failed. (0x12) Cannot access package list (.plist) file.


The v5.1.1b dir is at the root of the ftp.

In the Fabric OS manual the firmwareDownload process has several examples for the File Name: with double //'s as well as /'s.  I have tried both.  nothing works.

Could it be that the 5.0.1b firmware has some different upgrade process?

Any suggestions are welcome.


External Moderator
Posts: 5,644
Registered: ‎02-23-2004

Re: 200E firmware upgrade question

you have a DOUBLE "/" in the file name

>>> File Name: //v5.1.1b/release.plist

correct must

File Name: /v5.1.1b/release.plist


Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.