For more details, please see ourCookie Policy.

Application Delivery (ADX)

Posts: 22
Registered: ‎03-30-2011
Accepted Solution

vADX config-sync failing

[ Edited ]

Does anyone know what would cause config-sync to fail?   I had this working fine but when I tried to write mem from the sender today it failed to sync.  show config-sync status fails as well with the following messages and log:



SSH@vadx01-sender#show log
Syslog logging: enabled (0 messages dropped, 1 flushes, 0 overruns)
Buffer logging: level ACDMEINW, 3 messages logged
level code: A=alert C=critical D=debugging M=emergency E=error
I=informational N=notification W=warning
Dynamic Log Buffer (50 lines):
Jan 4 05:52:13:I:Incremental update from vadx01 to failed.
Jan 4 05:52:13:M:Peer image details not available.Please check sync status.
Jan 4 06:17:01:I:Interface ethernet3, state up
Jan 4 06:17:01:I:Interface ethernet2, state up
Jan 4 06:17:01:I:Interface ethernet1, state up
Jan 4 06:17:01:I:Config-sync mode changed from Sender to Receiver because of a HA flap
Jan  4 06:18:01:E:Failed to get peer image details: 2 attempt


vadx02 shows absolutely no update attempts from vadx01 in the logs.  IP connectivity is there and this was working a couple weeks ago and to the best of my knowledge no changes have been made that would break this.  If I reload 01 then 02 becomes the sender so that works, it just looks like the actual config-sync isn't working.   They are using the same port for HA and config-sync. 

Posts: 22
Registered: ‎03-30-2011

Re: vADX config-sync failing

[ Edited ]

Figured this out.  vADXs reside on seperate ESXi hosts using vdistributed switch which is dualhomed to 2 cisco switches.  I have a specifc port group for HA that I had to change the load balancing from original virtual port to IP hash (I have to do this for all port groups within this enivronment but never did for the HA vlan).  Once I did that config-sync started working again.


THe reason why it stopped working is because I vmotioned one of the vadxs to another host for redundancy, when they were on the same host conffig-sync worked.  


Hope this helps someone else.  

Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.