Wise Packaging

 View Only

MSI "Run as administrator" Context Menu for Vista 

Apr 03, 2007 11:15 AM

If you are using Vista with UAC enabled, you may have noticed that some existing MSI packages may not install as expected.

Here's a fix.

The reason is because Windows Installer by default doesn't elevate to higher privileges until it is about to actually start doing work in the install sequence. The attached .REG file adds a "Run as administrator" option to the context menu for .MSI files. This forces an elevation prompt before the .MSI is run so the entire install session is run with elevated privileges.
By downloading this software, you agree to the terms and conditions in the Altiris Juice Software License
Support:User-contributed tools on the Juice are not supported by Altiris Technical Support. If you have questions about a tool, please communicate directly with the author by visiting their profile page and clicking the 'contact' tab.

0 Favorited
1 Files
zip file
MsiRunAsAdmin.zip   391 B   1 version
Uploaded - Feb 25, 2020

Tags and Keywords


Mar 27, 2010 09:01 PM

Excellent.. Thanks

Sep 18, 2007 04:10 AM

Great stuff !!!!

Jul 31, 2007 03:21 PM

I use this all the time. It beats having to make an .EXE wrapper for the MSI in order to enable the right-click "Run as Administrator" option. It was a great find!

Apr 28, 2007 10:26 PM


Apr 10, 2007 01:53 PM

This registry setting is doing a great job, and makes the work easier.
You never forget to set the correct permission, because this reg key does it for you.
Great tip.

Apr 04, 2007 03:38 PM

I don't exactly understand your question. All this does is add a new context menu item in Windows Explorer for MSI files. It doesn't do anything to the packages themselves. This registry setting could be added to the WPS install itself so that it would be available to repackagers working with WPS on Vista.

Apr 04, 2007 09:54 AM

If you repackage w/the latest version of Wise Package Studio does it automatically add this check?

Apr 03, 2007 11:25 AM

I didn't try this way but I'll keep it in mind for the next time.
Thanks for this suggestion.

Related Entries and Links

No Related Resource entered.