Asset Management Suite

Expand all | Collapse all

Task server not installed on Parent server want to know how to install it detail steps plz

  • 1.  Task server not installed on Parent server want to know how to install it detail steps plz

    Posted 05-10-2021 01:11 PM
    When you check the screenshot , No Task server is there so I just want to know how to get the Task Server in Task status tab under Agent settings


    ------------------------------
    Shiv Choudhary
    ------------------------------


  • 2.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Broadcom Employee
    Posted 05-11-2021 12:11 AM
    Good morning!

    1. On Parent NS server, make sure that Task Server is installed and is running (Actually Task Server should be automatically installed or upgraded on Notification Server machine by default/design)

    2. If it is not installed, then open SMP Console -> "Settings" -> "Notification Server" -> "Site Server Settings"
    Check whether your parent NS already has assigned Task Server "Site Server" role (So task service record should be shown for Parent NS on this page like on this pic)


    If not, then click "New" button above on left side -> click "Site Server" -> now select your Parent NS machine  -> select Task Service role and click OK

    When Update membership will be completed, then on next policy refresh on Parent NS, Task Server installation rollout policy should appear and TS should be installed & running.

    ------------------------------
    Software QA Engineer
    Broadcom Inc.
    ------------------------------



  • 3.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Posted 05-11-2021 07:00 AM
    Hi Igor ,

    Thanks a lot !! for your reply & explaining everything in so much detail . You can clearly see in the below screenshot that Parent NS already has assigned Task Server "Site Server" role. But even after that No Task Server in Task status tab under Agent settings tab .
    Also the Altiris Object Host service is available on the server in Services & it's running . Plz suggest me further what to do so that Task server will be visible under Agent setting tab .



    Shiv Choudhary

    ------------------------------
    Tata Consultancy Services
    ------------------------------



  • 4.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Broadcom Employee
    Posted 05-11-2021 07:39 AM
    First, make sure that there is no "Manually Assigned Agents" specified resource targets which are excluding Parent NS itself
    Second, if you have there any Site(s) created which includes subnets but don't include subnet of Parent NS make sure that Site has Parent NS subnet in.
    On Parent NS, from start menu, open Altiris Log Viewer, then click "Reset Task Agent" in Symantec Management Agent UI and check logs to see why it doesn't register.

    ------------------------------
    Software QA Engineer
    Broadcom Inc.
    ------------------------------



  • 5.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Posted 05-11-2021 08:27 AM
    Hi Igor ,

    I have checked & find that in "Manually Assigned Agents" specified resource targets only Parent NS & it's corresponding site server is available there and nothing is there . Also while Resetting agent & checking the log in Altiris log Viewer I found that Client Task Agent has lost registration with Task Server.
    PFB the screenshot attached & also getting below warning in logs :
    Task Server operation failed: Client has no registration on Task Server
    Error code: 0x0000000D,
    Error description: Cannot post task status, there is no registration on Task Server.,
    Retry: Yes,
    Registration is lost: Yes

    Shiv Choudhary 


    ------------------------------
    Tata Consultancy Services
    ------------------------------



  • 6.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Broadcom Employee
    Posted 05-11-2021 10:35 AM

    I see that TS status is green so its version is up to date and also see that lot of tasks were processed by this Task server but suddenly it stopped to register clients to itself.

    Was there ITMS update to major 8.5 version or RU version?
    Is there any current pending reboot on this Parent NS, Windows updates were installed?

    What settings you have on Task Service Settings page?

    Default NS Communication profile has correct TLS .v settings enabled? Any proxy server settings there?

    Application Pool for Task Server is the same like on pic below & started?

    Check firewall inbound rules for Task Server services like on pic below



    ------------------------------
    Software QA Engineer
    Broadcom Inc.
    ------------------------------



  • 7.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Posted 05-12-2021 09:27 AM
    Edited by shiv.choudhary 05-12-2021 09:29 AM
    Hi Igor ,

    Yes we have recently upgraded our 5 child servers & a Parent server to SMP 8.5 from 8.0 HF6.
    But this issue was even before upgrade . There is no pending reboot on the Parent server & all windows update are also installed .

    Default NS Communication profile page showing errors as shown below :
    Existing profile '' contains the same FQDN and web application path. Existence of non-unique profiles can lead to connection problems if some outdated profile will be used by NS Agent.
    Also I have observed that TLS V 1.1 & 1.2 are not selected .
    Plz suggest what to do to resolve error on this page

    Application Pool for Task Server is almost same & started

    Firewall inbound rules for Task Server services as shown below :

    Shiv Choudhary
    ------------------------------
    Tata Consultancy Services
    ------------------------------



  • 8.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Broadcom Employee
    Posted 05-12-2021 10:00 AM
    Seems like you are on Child NS because there is an icon in NS communication profile and info message "Hierarchy managed item" above near with error message so you can't save changes. To change settings for NS communication profile (I believe this is Parent NS profile) need to open it directly from Parent NS Console and modify -> then via right click on it -> replicate to all existing Child NS servers.

    Could you please restart Altiris Object Host Service on parent NS where is problem with Client Task Agent registration, then in SMA UI try to "Register Client task agent" -> then gather logs from this server C:\ProgramData\Symantec\SMP\Logs & C:\ProgramData\Symantec\Symantec Agent\Logs

    ------------------------------
    Software QA Engineer
    Broadcom Inc.
    ------------------------------



  • 9.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Posted 05-12-2021 01:23 PM
    Edited by shiv.choudhary 05-12-2021 01:24 PM
    I followed the below article to resolve the error that we were getting above i.e.  Existing profile '' contains the same FQDN and web application path. Existence of non-unique profiles can lead to connection problems if some outdated profile will be used by NS Agent.
    https://knowledge.broadcom.com/external/article/184468/duplicate-symantec-management-agent-comm.html
    While performing the steps suggested in Article I found there is one Site Server , Parent Server & one field is there which is left blank (No name there, only GUID & other fields visible as shown in the screenshot on S.No. 1)
    So i just wanted to know that is this the entry which is not to be there . Should I add it's GUID to the ItemToDelete table & run the below query as suggested in the above article. PFA screenshot for more details . Plz suggest me further steps 

         insert into ItemToDelete 
         select  guid, GETDATE() 
         from item where guid = '<guid>'


    ------------------------------
    Tata Consultancy Services
    ------------------------------



  • 10.  RE: Task server not installed on Parent server want to know how to install it detail steps plz

    Broadcom Employee
    Posted 05-12-2021 10:54 PM
    First I would compare content of "State" column between this NS Communication profile which has name, description etc vs this one without name, description. If they are the same, then you can delete this empty name,description record, go to SMP Console, open working NS Communication profile, change required settings and save changes, then refresh policy on client side and try to register Client task agent.

    ------------------------------
    Software QA Engineer
    Broadcom Inc.
    ------------------------------