Client Management Suite

Expand all | Collapse all

Altiris CMS/SMP Migration From 7.0 to 7.1.

  • 1.  Altiris CMS/SMP Migration From 7.0 to 7.1.

    Posted 12-06-2010 06:26 PM

    Hey team,

    So we've got our 7.1 beta release up and running in our test tab. We have a 2008 off-box SQL server with a copy of our production and test/dev 7.0 databases.

    Has anyone begun testing their migration from 7.0 to 7.1?

    I tried a the basic 'use existing database' and pointed to a copy of our test 7.0 database and had it fail pretty quickly. I also tried running a full 7.1 install and pointing to the test 7.0 database during the initial configuration in SIM - that also failed.

    We have no issues installing 7.1, but major issues trying to get it to point to the old database.

    I can post logs if required, I'm just not entirely sure where they are/which ones you would need.

    Here is the use case for 7.0 -> 7.1 migration.

    Obviously this is still in beta, but I would very much like to begin testing this ASAP.

    Cheers

    Rhys



  • 2.  RE: Altiris CMS/SMP Migration From 7.0 to 7.1.

    Posted 12-08-2010 02:00 AM

    Hello Rhys,

     

    Confirm the collation of old database is same. it might happen that 7.0 database does not match with the database server. in this case, it will import the database but the instalaltion of SMP will fail.

    Also, the login user for database should be an administrator.



  • 3.  RE: Altiris CMS/SMP Migration From 7.0 to 7.1.

    Posted 12-08-2010 06:10 PM

    Unsure what you mean by collation though? Match with the database server? Could you please clarify.

    Cheers



  • 4.  RE: Altiris CMS/SMP Migration From 7.0 to 7.1.

    Posted 12-08-2010 06:31 PM
      |   view attached

    Please refer to the attached screenshot.

    To upgrade an existing 7.0 database to the 7.1 version using the database setting page, The database collation is required to be consistent. i.e. The collation you used when installing NS 7.1 shall be the same as the one used for the NS 7.0 server.

    Regards,



  • 5.  RE: Altiris CMS/SMP Migration From 7.0 to 7.1.

    Posted 12-09-2010 12:17 AM

    Yep the collation is the same. Even we when point to the production database it still fails (and the collation would have to be the same as its the same database).

    Any other suggestions?



  • 6.  RE: Altiris CMS/SMP Migration From 7.0 to 7.1.

    Posted 12-09-2010 12:21 AM

    Rhys,

    as in snap ny clili, it shows collation of the database, check the properties of SQL Server by right click on it and click on properties. it will display the collation. both should match.

    If they are not matching, you need to create an instance with the required collation (as in database).



  • 7.  RE: Altiris CMS/SMP Migration From 7.0 to 7.1.

    Posted 12-09-2010 12:26 AM

    try making a fresh database and install ITMS.

    Once installation is complete, from Settings | Notification Server | Database Settings, change the database and use your 7.0 database and save settings. this will use your old settings.

    This is workaround so try on test machine rather than going directly on production env.



  • 8.  RE: Altiris CMS/SMP Migration From 7.0 to 7.1.

    Posted 12-09-2010 04:32 AM

    Hi Rhys,

    Can you please share your SIM logs? Logs can be found in C:\Users\administrator\AppData\Local\Temp\1\SIM Logs.

     

    Regards